summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2014-08-24 09:39:32 +1200
committerRobert Collins <robertc@robertcollins.net>2014-08-24 09:39:32 +1200
commitfa80ecdc7cdf34b65487d867098c9e51d4146083 (patch)
treeff57f423daa008344f762476553ab01a5d491562
parent6c0f807eef65d924a89351e237ba7cdcf4e1cc1a (diff)
downloadtestrepository-git-fa80ecdc7cdf34b65487d867098c9e51d4146083.tar.gz
Make subunit 0.0.18 be a hard dependency.
The v2 protocol solves key issues in concurrency and stream handling. Users that cannot use subunit v2 can run an older testrepository, or contact upstream to work through whatever issue is blocking them.
-rw-r--r--INSTALL.txt2
-rw-r--r--NEWS5
-rwxr-xr-xsetup.py2
3 files changed, 7 insertions, 2 deletions
diff --git a/INSTALL.txt b/INSTALL.txt
index 70a80f1..b6ca194 100644
--- a/INSTALL.txt
+++ b/INSTALL.txt
@@ -6,7 +6,7 @@ Run time dependencies
* Python2.4 or newer.
-* subunit
+* subunit (0.0.18 or newer).
* fixtures (https://launchpad.net/python-fixtures, or
http://pypi.python.org/pypi/fixtures/).
diff --git a/NEWS b/NEWS
index 063a596..4ad26cf 100644
--- a/NEWS
+++ b/NEWS
@@ -18,6 +18,11 @@ CHANGES
* Test filtering was failing under python3 and would only apply the
filters to the first test listed by discover. (Clark Boylan, #1317607)
+* Version 0.0.18 of subunit is now a hard dependency - the v2 protocol solves
+ key issues in concurrency and stream handling. Users that cannot use subunit
+ v2 can run an older testrepository, or contact upstream to work through
+ whatever issue is blocking them. (Robert Collins)
+
* When list-tests encounters an error, a much clearer response will
now be shown. (Robert Collins, #1271133)
diff --git a/setup.py b/setup.py
index dcf04b6..9f38198 100755
--- a/setup.py
+++ b/setup.py
@@ -95,7 +95,7 @@ setup(name='testrepository',
],
install_requires=[
'fixtures',
- 'python-subunit >= 0.0.10',
+ 'python-subunit >= 0.0.18',
'testtools >= 0.9.30',
],
extras_require = dict(