summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjortel <devnull@localhost>2010-02-19 13:59:38 +0000
committerjortel <devnull@localhost>2010-02-19 13:59:38 +0000
commit6c5cb9d77eabc22ad84459bfccfdf5bd5f4a3f77 (patch)
tree85c4b93cf2487348c84c81d163c6061cbc98685d
parentcc1dd953b4b9427a98fcebe9e7dbf81ac18e62a8 (diff)
downloadsuds-6c5cb9d77eabc22ad84459bfccfdf5bd5f4a3f77.tar.gz
0.3.9 GA
-rw-r--r--python-suds.spec11
-rw-r--r--suds/__init__.py2
2 files changed, 11 insertions, 2 deletions
diff --git a/python-suds.spec b/python-suds.spec
index 88d4f15..186ae4d 100644
--- a/python-suds.spec
+++ b/python-suds.spec
@@ -56,7 +56,16 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Thu Dec 17 2009 jortel <jortel@redhat.com> - 0.3.9-1
- - Bumped python requires to 2.4
+- Bumped python requires to 2.4
+- Replaced stream-based caching in the transport package with document-based caching.
+- Caches pickled Document objects instead of XML text. 2x Faster!
+- No more SAX parsing exceptions on damaged or incomplete cached files.
+- Cached WSDL objects. Entire Definitions object including contained Schema object cached via pickle.
+- Copy of soap encoding schema packaged with suds.
+- Refactor Transports to use ProxyHandler instead of urllib2.Request.set_proxy().
+- Added WSSE enhancements <Timestamp/> and <Expires/> support. See: Timestamp token.
+- Fixed Tickets: #256, #291, #294, #295, #296
+
* Wed Dec 9 2009 jortel <jortel@redhat.com> - 0.3.8-1
- Includeds Windows NTLM Transport.
- Add missing self.messages in Client.clone().
diff --git a/suds/__init__.py b/suds/__init__.py
index 5e545cd..2a5d4b5 100644
--- a/suds/__init__.py
+++ b/suds/__init__.py
@@ -27,7 +27,7 @@ import sys
#
__version__ = '0.3.9'
-__build__="(beta) R658-20100210"
+__build__="GA R659-20100219"
#
# Exceptions