summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjortel <devnull@localhost>2010-10-15 13:48:05 +0000
committerjortel <devnull@localhost>2010-10-15 13:48:05 +0000
commit515ef5e515c34fcc4ab8ef5a49ac8624750365fe (patch)
treee0a566ee22b39a7bcda1d35047242c191ae5b3f8
parent0b62bc54546b3727ac3ae1b2c22691385b68e358 (diff)
downloadsuds-515ef5e515c34fcc4ab8ef5a49ac8624750365fe.tar.gz
Update epydocs and change RequestContext.sent -> RequestContext.envelope for readability.
-rw-r--r--python-suds.spec5
-rw-r--r--suds/__init__.py2
-rw-r--r--suds/client.py34
3 files changed, 37 insertions, 4 deletions
diff --git a/python-suds.spec b/python-suds.spec
index 72a31fb..8d40ac0 100644
--- a/python-suds.spec
+++ b/python-suds.spec
@@ -2,7 +2,7 @@
Summary: A python SOAP client
Name: python-suds
-Version: 0.4
+Version: 0.4.1
Release: 1%{?dist}
Source0: https://fedorahosted.org/releases/s/u/suds/%{name}-%{version}.tar.gz
License: LGPLv3+
@@ -54,6 +54,9 @@ rm -rf $RPM_BUILD_ROOT
%doc README LICENSE
%changelog
+* Thu Oct 15 2010 jortel <jortel@redhat.com> - 0.4.1-1
+- 0.4.1
+
* Thu Sep 8 2010 jortel <jortel@redhat.com> - 0.4-1
- Fix spelling errors in spec description.
- Fix source0 URL warning.
diff --git a/suds/__init__.py b/suds/__init__.py
index 961bbf4..2ffb50d 100644
--- a/suds/__init__.py
+++ b/suds/__init__.py
@@ -27,7 +27,7 @@ import sys
#
__version__ = '0.4.1'
-__build__="(beta) R701-20101015"
+__build__="(beta) R703-20101015"
#
# Exceptions
diff --git a/suds/client.py b/suds/client.py
index e242e44..1692b26 100644
--- a/suds/client.py
+++ b/suds/client.py
@@ -792,13 +792,38 @@ class SimClient(SoapClient):
class RequestContext:
+ """
+ A request context.
+ Returned when the ''nosend'' options is specified.
+ @ivar client: The suds client.
+ @type client: L{Client}
+ @ivar binding: The binding for this request.
+ @type binding: I{Binding}
+ @ivar envelope: The request soap envelope.
+ @type envelope: str
+ """
- def __init__(self, client, binding, sent):
+ def __init__(self, client, binding, envelope):
+ """
+ @param client: The suds client.
+ @type client: L{Client}
+ @param binding: The binding for this request.
+ @type binding: I{Binding}
+ @param envelope: The request soap envelope.
+ @type envelope: str
+ """
self.client = client
self.binding = binding
- self.sent = sent
+ self.envelope = envelope
def succeeded(self, reply):
+ """
+ Re-entry for processing a successful reply.
+ @param reply: The reply soap envelope.
+ @type reply: str
+ @return: The returned value for the invoked method.
+ @rtype: object
+ """
options = self.client.options
plugins = PluginContainer(options.plugins)
ctx = plugins.message.received(reply=reply)
@@ -806,5 +831,10 @@ class RequestContext:
return self.client.succeeded(self.binding, reply)
def failed(self, error):
+ """
+ Re-entry for processing a failure reply.
+ @param error: The error returned by the transport.
+ @type error: A suds I{TransportError}.
+ """
return self.client.failed(self.binding, error)
\ No newline at end of file