summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2015-10-23 12:24:53 +1300
committerRobert Collins <robertc@robertcollins.net>2015-10-23 12:24:53 +1300
commitfde1c723523315097f15a4c0ffa29ad69b6751b7 (patch)
treeca449a1ca8a61b290ec8e7635d04c31363a19a00
parent4810e55ba15d7239dbf63dbb390e36bc89253616 (diff)
downloadsubunit-fde1c723523315097f15a4c0ffa29ad69b6751b7.tar.gz
Release 1.2.
-rw-r--r--NEWS3
-rw-r--r--configure.ac2
-rw-r--r--python/subunit/__init__.py2
3 files changed, 5 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index f7acbbc..6368d74 100644
--- a/NEWS
+++ b/NEWS
@@ -8,6 +8,9 @@ NEXT (In development)
IMPROVEMENTS
~~~~~~~~~~~~
+* Fixed handling of incomplete writes with eventlet on Python3.
+ (Victor Stinner)
+
* Added subunit2disk, which explodes a stream out to files on disk.
(Robert Collins)
diff --git a/configure.ac b/configure.ac
index a7891a1..944e033 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
m4_define([SUBUNIT_MAJOR_VERSION], [1])
-m4_define([SUBUNIT_MINOR_VERSION], [1])
+m4_define([SUBUNIT_MINOR_VERSION], [2])
m4_define([SUBUNIT_MICRO_VERSION], [0])
m4_define([SUBUNIT_VERSION],
m4_defn([SUBUNIT_MAJOR_VERSION]).m4_defn([SUBUNIT_MINOR_VERSION]).m4_defn([SUBUNIT_MICRO_VERSION]))
diff --git a/python/subunit/__init__.py b/python/subunit/__init__.py
index 7d864e8..69acef5 100644
--- a/python/subunit/__init__.py
+++ b/python/subunit/__init__.py
@@ -153,7 +153,7 @@ from subunit.v2 import ByteStreamToStreamResult, StreamResultToBytes
# If the releaselevel is 'final', then the tarball will be major.minor.micro.
# Otherwise it is major.minor.micro~$(revno).
-__version__ = (1, 1, 0, 'final', 0)
+__version__ = (1, 2, 0, 'final', 0)
PROGRESS_SET = 0
PROGRESS_CUR = 1