summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2014-11-19 10:50:46 +1300
committerRobert Collins <robertc@robertcollins.net>2014-11-19 10:50:46 +1300
commitfc7299bf22b3c5ee53e86932656d0aa7a918b106 (patch)
treedd5c6de935f759a911924ee350d2baa4aadded5d
parenteb1f9f664dd96e7fb93a359d1bec99b92fd0ec1f (diff)
downloadsubunit-fc7299bf22b3c5ee53e86932656d0aa7a918b106.tar.gz
Release 1.0.0.1.0.0
-rw-r--r--Makefile.am2
-rw-r--r--NEWS3
-rw-r--r--README2
-rw-r--r--configure.ac4
-rw-r--r--python/subunit/__init__.py2
-rw-r--r--setup.cfg3
6 files changed, 11 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index e8f018e..765ae40 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
EXTRA_DIST = \
- .bzrignore \
+ .gitignore \
Apache-2.0 \
BSD \
INSTALL \
diff --git a/NEWS b/NEWS
index ed281ac..7bc8ee6 100644
--- a/NEWS
+++ b/NEWS
@@ -5,6 +5,9 @@ subunit release notes
NEXT (In development)
---------------------
+1.0.0
+-----
+
BUGFIXES
~~~~~~~~
diff --git a/README b/README
index dab8be7..76a7418 100644
--- a/README
+++ b/README
@@ -464,7 +464,7 @@ Releases
* Update versions in configure.ac and python/subunit/__init__.py.
* Update NEWS.
* Do a make distcheck, which will update Makefile etc.
-* Do a PyPI release: PYTHONPATH=../../python python ../../setup.py sdist upload -s
+* Do a PyPI release: PYTHONPATH=../../python python ../../setup.py sdist bdist_wheel upload -s
* Upload the regular one to LP.
* Push a tagged commit.
diff --git a/configure.ac b/configure.ac
index ef1a048..47071c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
-m4_define([SUBUNIT_MAJOR_VERSION], [0])
+m4_define([SUBUNIT_MAJOR_VERSION], [1])
m4_define([SUBUNIT_MINOR_VERSION], [0])
-m4_define([SUBUNIT_MICRO_VERSION], [21])
+m4_define([SUBUNIT_MICRO_VERSION], [0])
m4_define([SUBUNIT_VERSION],
m4_defn([SUBUNIT_MAJOR_VERSION]).m4_defn([SUBUNIT_MINOR_VERSION]).m4_defn([SUBUNIT_MICRO_VERSION]))
AC_PREREQ([2.59])
diff --git a/python/subunit/__init__.py b/python/subunit/__init__.py
index ca873b3..7f0aa8c 100644
--- a/python/subunit/__init__.py
+++ b/python/subunit/__init__.py
@@ -153,7 +153,7 @@ from subunit.v2 import ByteStreamToStreamResult, StreamResultToBytes
# If the releaselevel is 'final', then the tarball will be major.minor.micro.
# Otherwise it is major.minor.micro~$(revno).
-__version__ = (0, 0, 21, 'final', 0)
+__version__ = (1, 0, 0, 'final', 0)
PROGRESS_SET = 0
PROGRESS_CUR = 1
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..b8a1655
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,3 @@
+[bdist_wheel]
+universal = 1
+