summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--NEWS30
-rw-r--r--configure.ac2
-rw-r--r--python/subunit/__init__.py2
3 files changed, 32 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index 393ce8d..73f660a 100644
--- a/NEWS
+++ b/NEWS
@@ -5,6 +5,36 @@ subunit release notes
NEXT (In development)
---------------------
+1.4.0
+-----
+
+IMPROVEMENTS
+~~~~~~~~~~~~
+
+* Drop Python 3.3 support, and test on 3.5 and 3.6.
+ (Jelmer Vernooij)
+
+* Add support for Python 3.7 and 3.8.
+ (Matthew Treinish)
+
+* Improve readability of SubUnit v2 spec.
+ (Sergey Bronnikov)
+
+* Add license to setup.py. (Sergiu)
+
+BUGFIXES
+~~~~~~~~
+
+* Migrate Gtk interface to GObject introspection.
+ (Haikel Guemar)
+
+* Fix file open for python3. (Quique Llorente)
+
+* Check written bytes are not None before summing them to offset.
+ (Federico Ressi, #1845631)
+
+* Correctly handle py3 RawIOBase read(). (Stephen Finucane, partially #1813147)
+
1.3.0
-----
diff --git a/configure.ac b/configure.ac
index 7fa92ad..a06bd48 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
m4_define([SUBUNIT_MAJOR_VERSION], [1])
-m4_define([SUBUNIT_MINOR_VERSION], [3])
+m4_define([SUBUNIT_MINOR_VERSION], [4])
m4_define([SUBUNIT_MICRO_VERSION], [0])
m4_define([SUBUNIT_VERSION],
m4_defn([SUBUNIT_MAJOR_VERSION]).m4_defn([SUBUNIT_MINOR_VERSION]).m4_defn([SUBUNIT_MICRO_VERSION]))
diff --git a/python/subunit/__init__.py b/python/subunit/__init__.py
index 81b773c..17a970a 100644
--- a/python/subunit/__init__.py
+++ b/python/subunit/__init__.py
@@ -153,7 +153,7 @@ from subunit.v2 import ByteStreamToStreamResult, StreamResultToBytes
# If the releaselevel is 'final', then the tarball will be major.minor.micro.
# Otherwise it is major.minor.micro~$(revno).
-__version__ = (1, 3, 0, 'final', 0)
+__version__ = (1, 4, 0, 'final', 0)
PROGRESS_SET = 0
PROGRESS_CUR = 1