summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2023-01-28 15:32:39 +0000
committerGitHub <noreply@github.com>2023-01-28 15:32:39 +0000
commitf49eb718b7f863ccfcc8b57f3251d138036af6c6 (patch)
tree1ff8dcb6017fa8eef3e6cc3b3765e43ff2991875
parent08fd9efb71c7b6c2913244d490adf19b22599208 (diff)
parentfdb44353200a980c7dc5e43598ad88356cc1a8b8 (diff)
downloadsubunit-git-f49eb718b7f863ccfcc8b57f3251d138036af6c6.tar.gz
Merge pull request #60 from jelmer/py36
Drop support for eol python 3.6, add 3.11
-rw-r--r--.github/workflows/main.yml4
-rwxr-xr-xsetup.py4
2 files changed, 4 insertions, 4 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index 032fb33..cc8df7c 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -10,12 +10,12 @@ jobs:
runs-on: ${{ matrix.os }}
strategy:
matrix:
- python-version: ['3.6', '3.7', '3.8', '3.9', '3.10', 'pypy3']
+ python-version: ['3.7', '3.8', '3.9', '3.10', '3.11', 'pypy3.7']
os: ['ubuntu-latest']
steps:
- uses: actions/checkout@v2
- name: Set up Python ${{ matrix.python-version }}
- uses: actions/setup-python@v2
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python-version }}
- name: Install Deps
diff --git a/setup.py b/setup.py
index 54ba083..5ed67f4 100755
--- a/setup.py
+++ b/setup.py
@@ -37,11 +37,11 @@ setup(
'Operating System :: OS Independent',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
'Topic :: Software Development :: Testing',
],
keywords='python test streaming',
@@ -56,7 +56,7 @@ setup(
packages=['subunit', 'subunit.tests', 'subunit.filter_scripts'],
package_dir={'subunit': 'python/subunit'},
- python_requires=">=3.6",
+ python_requires=">=3.7",
install_requires=[
'extras',
'testtools>=0.9.34',