summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Finucane <stephenfin@redhat.com>2021-12-15 10:23:30 +0000
committerStephen Finucane <stephenfin@redhat.com>2021-12-15 10:46:30 +0000
commitb20c057d620bca121eeceb21251eb967a909d84c (patch)
tree29807ff94767f1e2292f0acb4f755f3607f4e8a9
parentcbaa3177ea546088c1383f1f01176754c19b52c2 (diff)
downloadsubunit-git-b20c057d620bca121eeceb21251eb967a909d84c.tar.gz
Add testing for Python 3.10
Signed-off-by: Stephen Finucane <stephenfin@redhat.com>
-rw-r--r--.github/workflows/main.yml4
-rw-r--r--NEWS6
-rwxr-xr-xsetup.py1
3 files changed, 9 insertions, 2 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index 3674b85..032fb33 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -10,8 +10,8 @@ jobs:
runs-on: ${{ matrix.os }}
strategy:
matrix:
- python-version: [3.6, 3.7, 3.8, 3.9, 'pypy3']
- os: ["ubuntu-latest"]
+ python-version: ['3.6', '3.7', '3.8', '3.9', '3.10', 'pypy3']
+ os: ['ubuntu-latest']
steps:
- uses: actions/checkout@v2
- name: Set up Python ${{ matrix.python-version }}
diff --git a/NEWS b/NEWS
index 4bf7493..a5c58b1 100644
--- a/NEWS
+++ b/NEWS
@@ -8,6 +8,12 @@ NEXT (In development)
IMPROVEMENTS
~~~~~~~~~~~~
+* Add support for Python 3.9
+ (Thomas Grainger)
+
+* Add support for Python 3.10
+ (Stephen Finucane)
+
* Drop support for Python 2.7, 3.4, and 3.5
(Stephen Finucane)
diff --git a/setup.py b/setup.py
index fb03073..ea8edf2 100755
--- a/setup.py
+++ b/setup.py
@@ -41,6 +41,7 @@ setup(
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
'Topic :: Software Development :: Testing',
],
keywords='python test streaming',