summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2009-03-28 19:39:25 +1100
committerRobert Collins <robertc@robertcollins.net>2009-03-28 19:39:25 +1100
commit670fd098fc65436f3e7644c59dab6e5ac45c358b (patch)
tree32b7b8840a6f71d1a28207e2fb3c5451cb2126ae
parentc0d01f2e88ab4f61599fb774003ed6733a21b972 (diff)
downloadsubunit-git-670fd098fc65436f3e7644c59dab6e5ac45c358b.tar.gz
Fix the updated check 0.9.6 patch to pass selftest.
-rw-r--r--c/check-subunit-0.9.6.patch148
1 files changed, 97 insertions, 51 deletions
diff --git a/c/check-subunit-0.9.6.patch b/c/check-subunit-0.9.6.patch
index b085b5f..056f682 100644
--- a/c/check-subunit-0.9.6.patch
+++ b/c/check-subunit-0.9.6.patch
@@ -1,6 +1,6 @@
=== modified file 'AUTHORS'
--- AUTHORS 2009-02-03 12:38:12 +0000
-+++ AUTHORS 2009-03-28 07:17:20 +0000
++++ AUTHORS 2009-03-28 06:48:39 +0000
@@ -20,6 +20,7 @@
Daniel Gollub (pthreads support)
Friedrich Beckmann (mingw and msvc port)
@@ -12,7 +12,7 @@
=== modified file 'NEWS'
--- NEWS 2008-12-29 14:46:39 +0000
-+++ NEWS 2009-03-28 07:17:20 +0000
++++ NEWS 2009-03-28 06:48:39 +0000
@@ -1,3 +1,9 @@
+In development:
+
@@ -26,7 +26,7 @@
=== modified file 'configure.ac'
--- configure.ac 2008-12-31 01:23:32 +0000
-+++ configure.ac 2009-03-28 07:17:20 +0000
++++ configure.ac 2009-03-28 07:31:57 +0000
@@ -74,6 +74,26 @@
AM_CONDITIONAL(NO_TIMEOUT_TESTS, test x"$enable_timeout_tests" = "xfalse")
@@ -65,7 +65,7 @@
+ enable_subunit=false
+ ;;
+ true)
-+ AC_MSG_ERROR([libunit is required for subunit protocol support. The homepage for subunit is https://launchpad.net/subunit/])
++ AC_MSG_ERROR([libsubunit is required for subunit protocol support. The homepage for subunit is https://launchpad.net/subunit/])
+ ;;
+ esac
+])
@@ -109,7 +109,7 @@
=== modified file 'doc/check.texi'
--- doc/check.texi 2009-03-12 21:05:05 +0000
-+++ doc/check.texi 2009-03-28 07:17:20 +0000
++++ doc/check.texi 2009-03-28 06:48:39 +0000
@@ -39,6 +39,7 @@
@author Chris Pickett
@author Fredrik Hugosson
@@ -209,7 +209,7 @@
=== modified file 'src/check.h.in'
--- src/check.h.in 2009-02-03 12:36:16 +0000
-+++ src/check.h.in 2009-03-28 07:17:20 +0000
++++ src/check.h.in 2009-03-28 06:48:39 +0000
@@ -280,6 +280,9 @@
CK_NORMAL, /* All failed tests */
CK_VERBOSE, /* All tests */
@@ -223,7 +223,7 @@
=== modified file 'src/check_impl.h'
--- src/check_impl.h 2009-02-03 12:36:16 +0000
-+++ src/check_impl.h 2009-03-28 07:17:20 +0000
++++ src/check_impl.h 2009-03-28 06:48:39 +0000
@@ -84,6 +84,7 @@
CLSTART_S,
CLEND_SR,
@@ -235,7 +235,7 @@
=== modified file 'src/check_log.c'
--- src/check_log.c 2008-12-31 21:41:27 +0000
-+++ src/check_log.c 2009-03-28 07:17:20 +0000
++++ src/check_log.c 2009-03-28 06:48:39 +0000
@@ -23,12 +23,16 @@
#include <stdlib.h>
#include <stdio.h>
@@ -397,7 +397,7 @@
=== modified file 'src/check_log.h'
--- src/check_log.h 2006-10-13 00:24:56 +0000
-+++ src/check_log.h 2009-03-28 07:17:20 +0000
++++ src/check_log.h 2009-03-28 08:21:45 +0000
@@ -26,6 +26,7 @@
void log_suite_start (SRunner *sr, Suite *s);
void log_suite_end (SRunner *sr, Suite *s);
@@ -419,7 +419,7 @@
=== modified file 'src/check_print.c'
--- src/check_print.c 2008-12-31 02:05:58 +0000
-+++ src/check_print.c 2009-03-28 07:17:20 +0000
++++ src/check_print.c 2009-03-28 06:48:39 +0000
@@ -54,6 +54,11 @@
static void srunner_fprint_summary (FILE *file, SRunner *sr,
enum print_output print_mode)
@@ -447,7 +447,7 @@
=== modified file 'src/check_run.c'
--- src/check_run.c 2009-02-03 12:36:16 +0000
-+++ src/check_run.c 2009-03-28 07:17:20 +0000
++++ src/check_run.c 2009-03-28 06:48:39 +0000
@@ -159,6 +159,7 @@
for (i = tfun->loop_start; i < tfun->loop_end; i++)
@@ -459,7 +459,7 @@
=== modified file 'src/check_str.c'
--- src/check_str.c 2008-12-31 02:05:58 +0000
-+++ src/check_str.c 2009-03-28 07:17:20 +0000
++++ src/check_str.c 2009-03-28 06:48:39 +0000
@@ -47,6 +47,20 @@
return rstr;
}
@@ -484,7 +484,7 @@
=== modified file 'src/check_str.h'
--- src/check_str.h 2006-10-13 00:24:56 +0000
-+++ src/check_str.h 2009-03-28 07:17:20 +0000
++++ src/check_str.h 2009-03-28 06:48:39 +0000
@@ -25,6 +25,12 @@
value has been malloc'd, and must be freed by the caller */
char *tr_str (TestResult *tr);
@@ -501,7 +501,7 @@
=== modified file 'tests/Makefile.am'
--- tests/Makefile.am 2009-02-03 12:36:16 +0000
-+++ tests/Makefile.am 2009-03-28 07:17:20 +0000
++++ tests/Makefile.am 2009-03-28 08:26:21 +0000
@@ -20,7 +20,7 @@
ex_xml_output \
ex_log_output
@@ -511,24 +511,67 @@
if NO_TIMEOUT_TESTS
check_check_CFLAGS = -DTIMEOUT_TESTS_ENABLED=0
+@@ -37,17 +37,18 @@
+ check_check_export_LDADD = $(top_builddir)/src/libcheck.la $(top_builddir)/lib/libcompat.la
+
+ check_check_SOURCES = \
+- check_check.h \
+- check_list.c \
+- check_check_sub.c \
+- check_check_master.c \
+- check_check_msg.c \
+- check_check_log.c \
+- check_check_limit.c \
+- check_check_fork.c \
+- check_check_fixture.c \
+- check_check_pack.c \
+- check_check_exit.c \
++ check_check.h \
++ check_list.c \
++ check_check_sub.c \
++ check_check_master.c \
++ check_check_msg.c \
++ check_check_log.c \
++ check_check_log_internal.c \
++ check_check_limit.c \
++ check_check_fork.c \
++ check_check_fixture.c \
++ check_check_pack.c \
++ check_check_exit.c \
+ check_check_main.c
+ check_check_LDADD = $(top_builddir)/src/libcheckinternal.la $(top_builddir)/lib/libcompat.la
+
-=== modified file 'tests/check_check_log.c'
---- tests/check_check_log.c 2008-12-30 01:40:50 +0000
-+++ tests/check_check_log.c 2009-03-28 07:17:20 +0000
-@@ -4,6 +4,9 @@
- #include <stdlib.h>
- #include <string.h>
- #include <check.h>
+=== modified file 'tests/check_check.h'
+--- tests/check_check.h 2009-02-03 12:36:16 +0000
++++ tests/check_check.h 2009-03-28 08:34:03 +0000
+@@ -20,6 +20,7 @@
+ Suite *make_list_suite(void);
+ Suite *make_msg_suite(void);
+ Suite *make_log_suite(void);
++Suite *make_log_internal_suite(void);
+ Suite *make_limit_suite(void);
+ Suite *make_fork_suite(void);
+ Suite *make_fixture_suite(void);
+
+=== added file 'tests/check_check_log_internal.c'
+--- tests/check_check_log_internal.c 1970-01-01 00:00:00 +0000
++++ tests/check_check_log_internal.c 2009-03-28 08:33:45 +0000
+@@ -0,0 +1,55 @@
++#include "../lib/libcompat.h"
++
++/* Tests for log related stuff in check which need non-exported functions. */
++
++#include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
++#include <check.h>
+#include <check_list.h>
+#include <check_impl.h>
+#include <check_log.h>
- #include "check_check.h"
-
-
-@@ -80,15 +83,40 @@
- }
- END_TEST
-
++#include "check_check.h"
++
++
+#if ENABLE_SUBUNIT
+START_TEST(test_init_logging_subunit)
+{
@@ -553,36 +596,39 @@
+END_TEST
+#endif
+
- Suite *make_log_suite(void)
- {
-
- Suite *s;
-- TCase *tc_core, *tc_core_xml;
-+ TCase *tc_core, *tc_core_xml, *tc_core_subunit;
-
- s = suite_create("Log");
- tc_core = tcase_create("Core");
- tc_core_xml = tcase_create("Core XML");
++Suite *make_log_internal_suite(void)
++{
++
++ Suite *s;
++ TCase *tc_core_subunit;
++
++ s = suite_create("Log");
+ tc_core_subunit = tcase_create("Core SubUnit");
-
- suite_add_tcase(s, tc_core);
- tcase_add_test(tc_core, test_set_log);
-@@ -100,6 +128,11 @@
- tcase_add_test(tc_core_xml, test_no_set_xml);
- tcase_add_test(tc_core_xml, test_double_set_xml);
-
++
+#if ENABLE_SUBUNIT
+ suite_add_tcase(s, tc_core_subunit);
+ tcase_add_test(tc_core_subunit, test_init_logging_subunit);
+#endif
+
- return s;
- }
-
++ return s;
++}
++
+
+=== modified file 'tests/check_check_main.c'
+--- tests/check_check_main.c 2009-02-03 12:36:16 +0000
++++ tests/check_check_main.c 2009-03-28 08:34:51 +0000
+@@ -20,6 +20,7 @@
+ srunner_add_suite(sr, make_list_suite());
+ srunner_add_suite(sr, make_msg_suite());
+ srunner_add_suite(sr, make_log_suite());
++ srunner_add_suite(sr, make_log_internal_suite());
+ srunner_add_suite(sr, make_limit_suite());
+ srunner_add_suite(sr, make_fork_suite());
+ srunner_add_suite(sr, make_fixture_suite());
=== modified file 'tests/ex_output.c'
--- tests/ex_output.c 2008-12-30 01:40:50 +0000
-+++ tests/ex_output.c 2009-03-28 07:17:20 +0000
++++ tests/ex_output.c 2009-03-28 06:57:20 +0000
@@ -4,6 +4,7 @@
#include <stdio.h>
#include <string.h>
@@ -630,7 +676,7 @@
=== modified file 'tests/test_output.sh'
--- tests/test_output.sh 2008-12-30 05:47:35 +0000
-+++ tests/test_output.sh 2009-03-28 07:17:20 +0000
++++ tests/test_output.sh 2009-03-28 07:59:52 +0000
@@ -1,5 +1,7 @@
#!/bin/sh
@@ -687,7 +733,7 @@
=== added file 'tests/test_vars.in'
--- tests/test_vars.in 1970-01-01 00:00:00 +0000
-+++ tests/test_vars.in 2009-03-28 07:17:20 +0000
++++ tests/test_vars.in 2009-03-28 06:48:39 +0000
@@ -0,0 +1,2 @@
+# defined to 1 if subunit is enabled
+export ENABLE_SUBUNIT=@ENABLE_SUBUNIT@