summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2014-08-24 18:00:49 +1200
committerRobert Collins <robertc@robertcollins.net>2014-08-24 18:00:49 +1200
commit50b2f7c2b607775da53cffceafaeb9dbead1e993 (patch)
treef2b4d85d6787cfd1eff2a75de68adc2584a4934a
parent63ea73bf3ad9106907eefa21e6f858040cfa0ed8 (diff)
downloadsubunit-git-50b2f7c2b607775da53cffceafaeb9dbead1e993.tar.gz
Fixes for release process.0.0.19
-rw-r--r--README6
-rwxr-xr-xsetup.py2
2 files changed, 5 insertions, 3 deletions
diff --git a/README b/README
index 668dca6..dab8be7 100644
--- a/README
+++ b/README
@@ -462,9 +462,9 @@ Releases
========
* Update versions in configure.ac and python/subunit/__init__.py.
-* Update Makefile in the root or do an inplace configure to get an updated Makefile.
* Update NEWS.
-* Make PyPI and regular tarball releases. Upload the regular one to LP, the
- PyPI one to PyPI.
+* Do a make distcheck, which will update Makefile etc.
+* Do a PyPI release: PYTHONPATH=../../python python ../../setup.py sdist upload -s
+* Upload the regular one to LP.
* Push a tagged commit.
diff --git a/setup.py b/setup.py
index 5a05002..8bc7921 100755
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,5 @@
#!/usr/bin/env python
+import os.path
try:
# If the user has setuptools / distribute installed, use it
from setuptools import setup
@@ -33,6 +34,7 @@ VERSION = (
or "0.0")
+os.chdir(os.path.dirname(__file__))
setup(
name='python-subunit',
version=VERSION,