summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2012-12-17 21:25:24 +1300
committerRobert Collins <robertc@robertcollins.net>2012-12-17 21:25:24 +1300
commitac5b23911197e70b75687f37d845bf9f0c5446fb (patch)
tree90f6751370db0d1463bce133e91f5ffcc717dd20
parentd32eef6a3fc4fb6dfbf6bfbccec9c8a6ddd91547 (diff)
downloadsubunit-git-0.0.9.tar.gz
Release 0.0.9.0.0.9
-rw-r--r--INSTALL2
-rw-r--r--MANIFEST.in1
-rw-r--r--README12
-rw-r--r--configure.ac2
-rw-r--r--python/subunit/__init__.py13
5 files changed, 27 insertions, 3 deletions
diff --git a/INSTALL b/INSTALL
index 2a053d8..eeea734 100644
--- a/INSTALL
+++ b/INSTALL
@@ -14,7 +14,7 @@ Dependencies
* Python for the filters
* 'testtools' (On Debian and Ubuntu systems the 'python-testtools' package,
the testtools package on pypi, or https://launchpad.net/testtools) for
- the extended test API which permits attachments. Version 0.9.11 or newer is
+ the extended test API which permits attachments. Version 0.9.23 or newer is
required. Of particular note, http://testtools.python-hosting.com/ is not
the testtools you want.
* A C compiler for the C bindings
diff --git a/MANIFEST.in b/MANIFEST.in
index 7c449cf..eb98981 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -16,6 +16,5 @@ exclude missing
prune perl
exclude py-compile
prune shell
-prune python/iso8601
exclude stamp-h1
include NEWS
diff --git a/README b/README
index 873a348..103a32c 100644
--- a/README
+++ b/README
@@ -215,3 +215,15 @@ to indicate a test that errored in some expected fashion (also know as "TODO"
tests in some frameworks). uxsuccess is used to indicate and unexpected success
where a test though to be failing actually passes. It is complementary to
xfail.
+
+Hacking on subunit
+------------------
+
+Releases
+========
+
+* Update versions in configure.ac and python/subunit/__init__.py.
+* Make PyPI and regular tarball releases. Upload the regular one to LP, the
+ PyPI one to PyPI.
+* Push a tagged commit.
+
diff --git a/configure.ac b/configure.ac
index 223b3c9..cf21d55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
m4_define([SUBUNIT_MAJOR_VERSION], [0])
m4_define([SUBUNIT_MINOR_VERSION], [0])
-m4_define([SUBUNIT_MICRO_VERSION], [8])
+m4_define([SUBUNIT_MICRO_VERSION], [9])
m4_define([SUBUNIT_VERSION],
m4_defn([SUBUNIT_MAJOR_VERSION]).m4_defn([SUBUNIT_MINOR_VERSION]).m4_defn([SUBUNIT_MICRO_VERSION]))
AC_PREREQ([2.59])
diff --git a/python/subunit/__init__.py b/python/subunit/__init__.py
index 749eda1..42dcf29 100644
--- a/python/subunit/__init__.py
+++ b/python/subunit/__init__.py
@@ -147,6 +147,19 @@ from testtools import testresult
from subunit import chunked, details, iso8601, test_results
+# same format as sys.version_info: "A tuple containing the five components of
+# the version number: major, minor, micro, releaselevel, and serial. All
+# values except releaselevel are integers; the release level is 'alpha',
+# 'beta', 'candidate', or 'final'. The version_info value corresponding to the
+# Python version 2.0 is (2, 0, 0, 'final', 0)." Additionally we use a
+# releaselevel of 'dev' for unreleased under-development code.
+#
+# If the releaselevel is 'alpha' then the major/minor/micro components are not
+# established at this point, and setup.py will use a version of next-$(revno).
+# If the releaselevel is 'final', then the tarball will be major.minor.micro.
+# Otherwise it is major.minor.micro~$(revno).
+
+__version__ = (0, 0, 9, 'final', 0)
PROGRESS_SET = 0
PROGRESS_CUR = 1