summaryrefslogtreecommitdiff
path: root/lib/sqlalchemy/orm/attributes.py
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2022-04-27 15:43:02 -0400
committerMike Bayer <mike_mp@zzzcomputing.com>2022-04-28 15:02:50 -0400
commitf2bd4f513628bb2a7a8e8b36383e3a4324eac803 (patch)
treec01bb4784f8bc47c14e4db7de4766ae9449c3026 /lib/sqlalchemy/orm/attributes.py
parentad11c482e2233f44e8747d4d5a2b17a995fff1fa (diff)
downloadsqlalchemy-f2bd4f513628bb2a7a8e8b36383e3a4324eac803.tar.gz
inline mypy config; files ignoring type errors for the moment
to simplify pyproject.toml change the remaining files that aren't going to be typed on this first pass (unless of course someone wants to type some of these) to include # mypy: ignore-errors. for the moment, only a handful of ORM modules are to have more type checking implemented. It's important that ignore-errors is used and not "# type: ignore", as in the latter case, mypy doesn't even read the existing types in the file, which makes it impossible to type any files that refer to those modules at all. to simplify ongoing typing work use inline mypy config for remaining files that are "done" for now, indicating the level of type checking they currently have. Change-Id: I98669c1a305c2f0adba85d10b5425541f3fe9533
Diffstat (limited to 'lib/sqlalchemy/orm/attributes.py')
-rw-r--r--lib/sqlalchemy/orm/attributes.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/sqlalchemy/orm/attributes.py b/lib/sqlalchemy/orm/attributes.py
index 619af6510..9a6e94e22 100644
--- a/lib/sqlalchemy/orm/attributes.py
+++ b/lib/sqlalchemy/orm/attributes.py
@@ -4,6 +4,7 @@
#
# This module is part of SQLAlchemy and is released under
# the MIT License: https://www.opensource.org/licenses/mit-license.php
+# mypy: ignore-errors
"""Defines instrumentation for class attributes and their interaction
with instances.
@@ -80,7 +81,6 @@ if TYPE_CHECKING:
from .state import InstanceState
from ..sql.dml import _DMLColumnElement
from ..sql.elements import ColumnElement
- from ..sql.elements import SQLCoreOperations
_T = TypeVar("_T")