summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini26
1 files changed, 23 insertions, 3 deletions
diff --git a/tox.ini b/tox.ini
index aab860e..e247ac1 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
minversion = 1.6
skipsdist = True
-envlist = py26,py27,py26sa07,py27sa07,py33,pep8
+envlist = py26,py27,py26sa07,py27sa07,py26sa08,py27sa08,py26sa09,py27sa09,py33,pep8
[testenv]
usedevelop = True
@@ -13,11 +13,11 @@ commands =
python setup.py testr --slowest --testr-args='{posargs} --concurrency=1'
[testenv:py26]
-deps = sqlalchemy>=0.8,<=0.8.99
+deps = sqlalchemy>=0.9
-r{toxinidir}/test-requirements.txt
[testenv:py27]
-deps = sqlalchemy>=0.8,<=0.8.99
+deps = sqlalchemy>=0.9
-r{toxinidir}/test-requirements.txt
[testenv:py26sa07]
@@ -25,11 +25,31 @@ basepython = python2.6
deps = sqlalchemy>=0.7,<=0.7.99
-r{toxinidir}/test-requirements.txt
+[testenv:py26sa08]
+basepython = python2.6
+deps = sqlalchemy>=0.8,<=0.8.99
+ -r{toxinidir}/test-requirements.txt
+
+[testenv:py26sa09]
+basepython = python2.6
+deps = sqlalchemy>=0.9,<=0.9.99
+ -r{toxinidir}/test-requirements.txt
+
[testenv:py27sa07]
basepython = python2.7
deps = sqlalchemy>=0.7,<=0.7.99
-r{toxinidir}/test-requirements.txt
+[testenv:py27sa08]
+basepython = python2.7
+deps = sqlalchemy>=0.8,<=0.8.99
+ -r{toxinidir}/test-requirements.txt
+
+[testenv:py27sa09]
+basepython = python2.7
+deps = sqlalchemy>=0.9,<=0.9.99
+ -r{toxinidir}/test-requirements.txt
+
[testenv:pep8]
commands = flake8