summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--requirements.txt5
-rw-r--r--tox.ini8
2 files changed, 12 insertions, 1 deletions
diff --git a/requirements.txt b/requirements.txt
index 41e51fd..b576693 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,5 +1,8 @@
pbr>=0.5.21,<1.0
-SQLAlchemy>=0.7.8,<=0.7.99
+# never put a cap on this, *ever*, sqla versions are handled via
+# tox, and if SQLA is capped it will only make it so we aren't testing
+# against all the versions we are compatible with.
+SQLAlchemy>=0.7.8
decorator
Tempita >= 0.4
diff --git a/tox.ini b/tox.ini
index 88f00db..aab860e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -12,6 +12,14 @@ deps = -r{toxinidir}/requirements.txt
commands =
python setup.py testr --slowest --testr-args='{posargs} --concurrency=1'
+[testenv:py26]
+deps = sqlalchemy>=0.8,<=0.8.99
+ -r{toxinidir}/test-requirements.txt
+
+[testenv:py27]
+deps = sqlalchemy>=0.8,<=0.8.99
+ -r{toxinidir}/test-requirements.txt
+
[testenv:py26sa07]
basepython = python2.6
deps = sqlalchemy>=0.7,<=0.7.99