summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Dague <sean.dague@samsung.com>2014-02-23 11:08:25 -0500
committerSean Dague <sean.dague@samsung.com>2014-02-23 11:38:53 -0500
commitfe148d87b41c5546fb03dddddda028a9fdd79b45 (patch)
tree1b9d789efc5ff8f166597f29b14493e567c673a1
parentd58e47f85c4ffd7bb2200acd0db8d9bc033db6be (diff)
downloadsqalchemy-migrate-fe148d87b41c5546fb03dddddda028a9fdd79b45.tar.gz
uncap SQLA in requirements.txt0.8.5
migrate can't just take a global requirements sync because it needs to be tested against multiple versions of SQLA to assure compatibility. A recent change had the effect of only testing migrate against SQLA 0.7, which is definitely *not* what we want to be doing. this reverts that change, and leaves very specific comments to hopefully prevent this from happening in the future. Change-Id: Icb4e136f0de6caa224019bb955341c4b67c5e1a1
-rw-r--r--requirements.txt5
-rw-r--r--tox.ini8
2 files changed, 12 insertions, 1 deletions
diff --git a/requirements.txt b/requirements.txt
index 41e51fd..b576693 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,5 +1,8 @@
pbr>=0.5.21,<1.0
-SQLAlchemy>=0.7.8,<=0.7.99
+# never put a cap on this, *ever*, sqla versions are handled via
+# tox, and if SQLA is capped it will only make it so we aren't testing
+# against all the versions we are compatible with.
+SQLAlchemy>=0.7.8
decorator
Tempita >= 0.4
diff --git a/tox.ini b/tox.ini
index 88f00db..aab860e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -12,6 +12,14 @@ deps = -r{toxinidir}/requirements.txt
commands =
python setup.py testr --slowest --testr-args='{posargs} --concurrency=1'
+[testenv:py26]
+deps = sqlalchemy>=0.8,<=0.8.99
+ -r{toxinidir}/test-requirements.txt
+
+[testenv:py27]
+deps = sqlalchemy>=0.8,<=0.8.99
+ -r{toxinidir}/test-requirements.txt
+
[testenv:py26sa07]
basepython = python2.6
deps = sqlalchemy>=0.7,<=0.7.99