summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-09-30 10:31:52 -0400
committerMonty Taylor <mordred@inaugust.com>2013-10-07 12:02:24 -0400
commit2ac02e0ef57b61c01d5684a03334bd013a1c7b1a (patch)
tree29d7daa00e063b9ca34d879701871bd7a408af17 /setup.py
parent5c646eb55859206274e2118255f582e4d17d73e8 (diff)
downloadsqalchemy-migrate-2ac02e0ef57b61c01d5684a03334bd013a1c7b1a.tar.gz
Stop using the d2to1-based pbr
pbr updated itself to remove the d2to1 dependency. One of the main reasons for this is a direct upstream dependency on distribute, which causes the distribute/setuptools merge bug to get triggered, which breaks people's system if they install with pip < 1.4. Remove d2to1 references, and also bump the required version requested of pbr to a version late enough to no longer depend on d2to1. Remove the version specifier from setup.py, because setup_requires has no way to trigger a version requirement upgrade. The flat version should be sufficient for the setup.py interface in perpetuity. Remove the setup-hook from setup.cfg, as it is no longer needed. Change-Id: I40d3507c77802d13fd894aa16714b2ed6aa7d59f
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index b3e85a7..c0a24ea 100644
--- a/setup.py
+++ b/setup.py
@@ -17,5 +17,5 @@
import setuptools
setuptools.setup(
- setup_requires=['d2to1>=0.2.10,<0.3', 'pbr>=0.5.10,<0.6'],
- d2to1=True)
+ setup_requires=['pbr'],
+ pbr=True)