summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Podolyaka <rpodolyaka@mirantis.com>2013-07-24 12:20:12 +0300
committerRoman Podolyaka <rpodolyaka@mirantis.com>2013-08-05 10:40:55 +0300
commitddea3a8bc8c5cf4b927c4cf97bfc82e4ffd0826a (patch)
treeee3b2a73f2ec093cef03d54533d8b26cbbdf759f
parent427149eef2b3ab774021595a785a9706808b64b6 (diff)
downloadsqalchemy-migrate-ddea3a8bc8c5cf4b927c4cf97bfc82e4ffd0826a.tar.gz
Run tests with different SQLAlchemy versions
The test suite should be run for all possible combinations of Python and SQLAlchemy versions we claim to support, which are Python 2.6 and 2.7 and SQLAlchemy 0.7.x (old stable) and 0.8.x (mainline stable). py26/py27 tox envs install the latest stable version of SQLAlchemy (currently, 0.8.x branch), so two additional tox environments added to run the test suite with SQLAlchemy 0.7.x (for both Python 2.6 and 2.7). Change-Id: I50c7009d8b808ce3bbb1f0a27c50f5cb5116cdb3
-rw-r--r--tox.ini12
1 files changed, 11 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index eca9a3f..eb0fb79 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,py33,pep8
+envlist = py26,py27,py26sa07,py27sa07,py33,pep8
[testenv]
setenv = VIRTUAL_ENV={envdir}
@@ -8,6 +8,16 @@ deps = -r{toxinidir}/requirements.txt
commands =
python setup.py testr --slowest --testr-args='{posargs}'
+[testenv:py26sa07]
+basepython = python2.6
+deps = sqlalchemy>=0.7,<=0.7.99
+ -r{toxinidir}/test-requirements.txt
+
+[testenv:py27sa07]
+basepython = python2.7
+deps = sqlalchemy>=0.7,<=0.7.99
+ -r{toxinidir}/test-requirements.txt
+
[testenv:pep8]
commands = flake8