summaryrefslogtreecommitdiff
path: root/doc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile')
-rw-r--r--doc/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/doc/Makefile b/doc/Makefile
index bfd5ca83..48a66ed1 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -9,9 +9,9 @@ PAPER =
PAPEROPT_a4 = -D latex_paper_size=a4
PAPEROPT_letter = -D latex_paper_size=letter
ALLSPHINXOPTS = -d _build/doctrees $(PAPEROPT_$(PAPER)) \
- $(SPHINXOPTS) .
+ $(SPHINXOPTS) $(O) .
-.PHONY: help clean html dirhtml pickle htmlhelp qthelp latex changes linkcheck doctest
+.PHONY: help clean html dirhtml pickle htmlhelp qthelp latex changes linkcheck doctest man
help:
@echo "Please use \`make <target>' where <target> is one of"
@@ -21,6 +21,7 @@ help:
@echo " htmlhelp to make HTML files and a HTML help project"
@echo " epub to make an epub file"
@echo " latex to make LaTeX files, you can set PAPER=a4 or PAPER=letter"
+ @echo " man to make manual pages"
@echo " changes to make an overview over all changed/added/deprecated items"
@echo " linkcheck to check all external links for integrity"
@@ -47,6 +48,11 @@ text:
@echo
@echo "Build finished."
+man:
+ $(SPHINXBUILD) -b man $(ALLSPHINXOPTS) _build/man
+ @echo
+ @echo "Build finished."
+
pickle:
$(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) _build/pickle