summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py20
-rw-r--r--tox.ini12
2 files changed, 8 insertions, 24 deletions
diff --git a/setup.py b/setup.py
index ca41aa43..720dc77b 100644
--- a/setup.py
+++ b/setup.py
@@ -46,25 +46,9 @@ A development egg can be found `here
requires = ['Pygments>=1.2', 'Jinja2>=2.3', 'docutils>=0.7']
-if sys.version_info < (2, 4):
- print('ERROR: Sphinx requires at least Python 2.4 to run.')
- sys.exit(1)
-
if sys.version_info < (2, 5):
- # Python 2.4's distutils doesn't automatically install an egg-info,
- # so an existing docutils install won't be detected -- in that case,
- # remove the dependency from setup.py
- try:
- import docutils
- if int(docutils.__version__[2]) < 4:
- raise ValueError('docutils not recent enough')
- except:
- pass
- else:
- del requires[-1]
-
- # The uuid module is new in the stdlib in 2.5
- requires.append('uuid>=1.30')
+ print('ERROR: Sphinx requires at least Python 2.5 to run.')
+ sys.exit(1)
# Provide a "compile_catalog" command that also creates the translated
diff --git a/tox.ini b/tox.ini
index ef61bdef..bfb50e39 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist=py24,py25,py26,py27,py31,py32,pypy,du08,du07,du06,du05
+envlist=py25,py26,py27,py31,py32,pypy,du09,du08,du07
[testenv]
deps=
@@ -10,11 +10,6 @@ commands=
{envpython} tests/run.py {posargs}
sphinx-build -W -b html -d {envtmpdir}/doctrees doc {envtmpdir}/html
-[testenv:py24]
-deps=
- nose
- simplejson==2.1.0
-
[testenv:py25]
deps=
nose
@@ -44,3 +39,8 @@ deps=
deps=
nose
docutils==0.8.1
+
+[testenv:du09]
+deps=
+ nose
+ docutils==0.9.1