summaryrefslogtreecommitdiff
path: root/CHANGES
diff options
context:
space:
mode:
authorshimizukawa <shimizukawa@gmail.com>2014-10-09 22:05:20 +0900
committershimizukawa <shimizukawa@gmail.com>2014-10-09 22:05:20 +0900
commit6075136a5b59e5fdb1b2dafd5f890f039a380ed3 (patch)
tree0bc00da1029be105a4e609397ef1595a11e84e5c /CHANGES
parentaeb2cb53f39d72622813c805db52dee7b2aac3ad (diff)
parentd85167a99b5ef2e2b9e98e287b8097580b3c8b1d (diff)
downloadsphinx-6075136a5b59e5fdb1b2dafd5f890f039a380ed3.tar.gz
merge with stable
Diffstat (limited to 'CHANGES')
-rw-r--r--CHANGES327
1 files changed, 241 insertions, 86 deletions
diff --git a/CHANGES b/CHANGES
index 24bef95f..66d4690a 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,28 +1,183 @@
-Release 1.2.4 (in development)
-==============================
+Release 1.3 (in development)
+============================
+
+Incompatible changes
+--------------------
+
+* Dropped support for Python 2.5, 3.1 and 3.2.
+* Dropped support for docutils versions up to 0.9.
+* Removed the ``sphinx.ext.oldcmarkup`` extension.
+* The deprecated config values ``exclude_trees``, ``exclude_dirnames`` and
+ ``unused_docs`` have been removed.
+* A new node, ``sphinx.addnodes.literal_strong``, has been added, for text that
+ should appear literally (i.e. no smart quotes) in strong font. Custom writers
+ will have to be adapted to handle this node.
+* PR#269, #1476: replace ``<tt>`` tag by ``<code>``. User customized stylesheets
+ should be updated If the css contain some styles for ``tt>`` tag.
+ Thanks to Takeshi Komiya.
+* #1543: `templates_path` is automatically added to
+ `exclude_patterns` to avoid reading autosummary rst templates in the
+ templates directory.
+* Custom domains should implement the new `Domain.resolve_any_xref`
+ method to make the `any` role work properly.
+* gettext builder: gettext doesn't emit uuid information to generated pot files
+ by default. Please set ``True`` to `gettext_uuid` to emit uuid information.
+ Additionally, if the ``python-levenshtein`` 3rd-party package is installed,
+ it will improve the calculation time.
+* gettext builder: disable extracting/apply 'index' node by default. Please set
+ 'index' to :confval:`gettext_enables` to enable extracting index entries.
+* PR#307: Add frame to code-block in LaTeX. Thanks to Takeshi Komiya.
Features added
--------------
+* Add support for Python 3.4.
+* Add support for docutils 0.12
+* Added ``sphinx.ext.napoleon`` extension for NumPy and Google style docstring
+ support.
+* Added support for parallel reading (parsing) of source files with the
+ `sphinx-build -j` option. Third-party extensions will need to be checked for
+ compatibility and may need to be adapted if they store information in the
+ build environment object. See `env-merge-info`.
+* Added the `any` role that can be used to find a cross-reference of
+ *any* type in *any* domain. Custom domains should implement the new
+ `Domain.resolve_any_xref` method to make this work properly.
* Exception logs now contain the last 10 messages emitted by Sphinx.
+* Added support for extension versions (a string returned by ``setup()``, these
+ can be shown in the traceback log files). Version requirements for extensions
+ can be specified in projects using the new `needs_extensions` config
+ value.
+* Changing the default role within a document with the :dudir:`default-role`
+ directive is now supported.
+* PR#214: Added stemming support for 14 languages, so that the built-in document
+ search can now handle these. Thanks to Shibukawa Yoshiki.
+* PR#296, PR#303, #76: numfig feature: Assign numbers to figures, tables and
+ code-blocks. This feature is configured with `numfig`, `numfig_secnum_depth`
+ and `numfig_prefix`. Also `numref` role is available. Thanks to Takeshi
+ Komiya.
+* PR#202: Allow "." and "~" prefixed references in ``:param:`` doc fields
+ for Python.
+* PR#184: Add `autodoc_mock_imports`, allowing to mock imports of
+ external modules that need not be present when autodocumenting.
+* #925: Allow list-typed config values to be provided on the command line,
+ like ``-D key=val1,val2``.
+* #668: Allow line numbering of `code-block` and `literalinclude` directives
+ to start at an arbitrary line number, with a new ``lineno-start`` option.
+* PR#172, PR#266: The `code-block` and `literalinclude`
+ directives now can have a ``caption`` option that shows a filename before the
+ code in the output. Thanks to Nasimul Haque, Takeshi Komiya.
+* Prompt for the document language in sphinx-quickstart.
+* PR#217: Added config values to suppress UUID and location information in
+ generated gettext catalogs.
+* PR#236, #1456: apidoc: Add a -M option to put module documentation before
+ submodule documentation. Thanks to Wes Turner and Luc Saffre.
+* #1434: Provide non-minified JS files for jquery.js and underscore.js to
+ clarify the source of the minified files.
+* PR#252, #1291: Windows color console support. Thanks to meu31.
+* PR#255: When generating latex references, also insert latex target/anchor
+ for the ids defined on the node. Thanks to Olivier Heurtier.
+* PR#229: Allow registration of other translators. Thanks to Russell Sim.
+* Add app.set_translator() API to register or override a Docutils translator
+ class like `html_translator_class`.
+* PR#267, #1134: add 'diff' parameter to literalinclude. Thanks to Richard Wall
+ and WAKAYAMA shirou.
+* PR#272: Added 'bizstyle' theme. Thanks to Shoji KUMAGAI.
+* Automatically compile ``*.mo`` files from ``*.po`` files when
+ `gettext_auto_build` is True (default) and ``*.po`` is newer than
+ ``*.mo`` file.
+* #623: `sphinx.ext.viewcode` supports imported function/class aliases.
+* PR#275: `sphinx.ext.intersphinx` supports multiple target for the
+ inventory. Thanks to Brigitta Sipocz.
+* PR#261: Added the `env-before-read-docs` event that can be connected to modify
+ the order of documents before they are read by the environment.
+* #1284: Program options documented with :rst:dir:`option` can now start with
+ ``+``.
+* PR#291: The caption of :rst:dir:`code-block` is recognised as a title of ref
+ target. Thanks to Takeshi Komiya.
+* PR#298: Add new API: :meth:`~sphinx.application.Sphinx.add_latex_package`.
+ Thanks to Takeshi Komiya.
+* #1344: add :confval:`gettext_enables` to enable extracting 'index' to gettext
+ catalog output / applying translation catalog to generated documentation.
+* PR#301, #1583: Allow the line numbering of the directive `literalinclude` to
+ match that of the included file, using a new ``lineno-match`` option. Thanks
+ to Jeppe Pihl.
+* PR#299: add various options to sphinx-quickstart. Quiet mode option
+ ``--quiet`` will skips wizard mode. Thanks to WAKAYAMA shirou.
Bugs fixed
----------
-* Now sphinx.ext.autodoc work with python-2.5 again.
+* #1438: Updated jQuery version from 1.8.3 to 1.11.1.
+* #1568: Fix a crash when a "centered" directive contains a reference.
* #1563: :meth:`~sphinx.application.Sphinx.add_search_language` raises
AssertionError for correct type of argument. Thanks to rikoman.
-* #1568: fix a crash when a "centered" directive contains a reference.
-* PR#288, #1512: env.record_dependency crashes on non-ASCII directories that
- relates to dependency files management like :rst:dir:`include` or
- :rst:dir:`csv-table`. Thanks to Takeshi Komiya.
-* PR#285: Test for subclasses of docutils node types when screening
- searchindex. Thanks to Nathan Goldbaum.
-* #1576: Special toctree entry "self" located after another entry that also has
- a toctree was replaced with wrong title and link.
+* #1174: Fix smart quotes being applied inside roles like :rst:role:`program` or
+ `makevar`.
+* PR#235: comment db schema of websupport lacked a length of the node_id field.
+ Thanks to solos.
+* #1466,PR#241: Fix failure of the cpp domain parser to parse C+11
+ "variadic templates" declarations. Thanks to Victor Zverovich.
+* #1459,PR#244: Fix default mathjax js path point to ``http://`` that cause
+ mixed-content error on HTTPS server. Thanks to sbrandtb and robo9k.
+* PR#157: autodoc remove spurious signatures from @property decorated
+ attributes. Thanks to David Ham.
+* PR#159: Add coverage targets to quickstart generated Makefile and make.bat.
+ Thanks to Matthias Troffaes.
+* #1251: When specifying toctree :numbered: option and :tocdepth: metadata,
+ sub section number that is larger depth than ``:tocdepth:`` is shrunk.
+* PR#260: Encode underscore in citation labels for latex export. Thanks to
+ Lennart Fricke.
+* PR#264: Fix could not resolve xref for figure node with :name: option.
+ Thanks to Takeshi Komiya.
+* PR#265: Fix could not capture caption of graphviz node by xref. Thanks to
+ Takeshi Komiya.
+* PR#263, #1013, #1103: Rewrite of C++ domain. Thanks to Jakob Lykke Andersen.
+
+ * Hyperlinks to all found nested names and template arguments (#1103).
+ * Support for function types everywhere, e.g., in
+ std::function<bool(int, int)> (#1013).
+ * Support for virtual functions.
+ * Changed interpretation of function arguments to following standard
+ prototype declarations, i.e., void f(arg) means that arg is the type of the
+ argument, instead of it being the name.
+ * Updated tests.
+ * Updated documentation with elaborate description of what declarations are
+ supported and how the namespace declarations influence declaration and
+ cross-reference lookup.
+ * Index names may be different now. Elements are indexed by their fully
+ qualified name. It should be rather easy to change this behaviour and
+ potentially index by namespaces/classes as well.
+
+* PR#258, #939: Add dedent option for `code-block` and
+ `literalinclude`. Thanks to Zafar Siddiqui.
+* PR#268: Fix numbering section does not work at singlehtml mode. It still
+ ad-hoc fix because there is a issue that section IDs are conflicted.
+ Thanks to Takeshi Komiya.
+* PR#273, #1536: Fix RuntimeError with numbered circular toctree. Thanks to
+ Takeshi Komiya.
+* PR#274: Set its URL as a default title value if URL appears in toctree.
+ Thanks to Takeshi Komiya.
+* PR#276, #1381: `rfc` and `pep` roles support custom link
+ text. Thanks to Takeshi Komiya.
+* PR#277, #1513: highlights for function pointers in argument list of
+ `c:function`. Thanks to Takeshi Komiya.
+* PR#278: Fix section entries were shown twice if toctree has been put under
+ only directive. Thanks to Takeshi Komiya.
+* #1547: pgen2 tokenizer doesn't recognize ``...`` literal (Ellipsis for py3).
+* PR#294: On LaTeX builder, wrap float environment on writing literal_block
+ to avoid separation of caption and body. Thanks to Takeshi Komiya.
+* PR#295, #1520: ``make.bat latexpdf`` mechanism to ``cd`` back to the current
+ directory. Thanks to Peter Suter.
+* PR#297, #1571: Add imgpath property to all builders. It make easier to
+ develop builder extensions. Thanks to Takeshi Komiya.
* #1584: Point to master doc in HTML "top" link.
* #1585: Autosummary of modules broken in Sphinx-1.2.3.
+Documentation
+-------------
+
+* Add clarification about the syntax of tags. (:file:`doc/markup/misc.rst`)
+
Release 1.2.3 (released Sep 1, 2014)
====================================
@@ -30,7 +185,7 @@ Release 1.2.3 (released Sep 1, 2014)
Features added
--------------
-* #1518: `sphinx-apidoc` command now have a `--version` option to show version
+* #1518: ``sphinx-apidoc`` command now has a ``--version`` option to show version
information and exit
* New locales: Hebrew, European Portuguese, Vietnamese.
@@ -48,14 +203,14 @@ Bugs fixed
Thanks to Jorge_C.
* #1467: Exception on Python3 if nonexistent method is specified by automethod
* #1441: autosummary can't handle nested classes correctly.
-* #1499: With non-callable `setup` in a conf.py, now sphinx-build emits
- user-friendly error message.
+* #1499: With non-callable ``setup`` in a conf.py, now sphinx-build emits
+ a user-friendly error message.
* #1502: In autodoc, fix display of parameter defaults containing backslashes.
* #1226: autodoc, autosummary: importing setup.py by automodule will invoke
- setup process and execute `sys.exit()`. Now sphinx avoids SystemExit
+ setup process and execute ``sys.exit()``. Now sphinx avoids SystemExit
exception and emits warnings without unexpected termination.
* #1503: py:function directive generate incorrectly signature when specifying
- a default parameter with an empty list `[]`. Thanks to Geert Jansen.
+ a default parameter with an empty list ``[]``. Thanks to Geert Jansen.
* #1508: Non-ASCII filename raise exception on make singlehtml, latex, man,
texinfo and changes.
* #1531: On Python3 environment, docutils.conf with 'source_link=true' in the
@@ -65,11 +220,11 @@ Bugs fixed
* PR#281, PR#282, #1509: TODO extension not compatible with websupport. Thanks
to Takeshi Komiya.
* #1477: gettext does not extract nodes.line in a table or list.
-* #1544: `make text` generate wrong table when it has empty table cells.
+* #1544: ``make text`` generates wrong table when it has empty table cells.
* #1522: Footnotes from table get displayed twice in LaTeX. This problem has
been appeared from Sphinx-1.2.1 by #949.
* #508: Sphinx every time exit with zero when is invoked from setup.py command.
- ex. `python setup.py build_sphinx -b doctest` return zero even if doctest
+ ex. ``python setup.py build_sphinx -b doctest`` return zero even if doctest
failed.
Release 1.2.2 (released Mar 2, 2014)
@@ -78,7 +233,7 @@ Release 1.2.2 (released Mar 2, 2014)
Bugs fixed
----------
-* PR#211: When checking for existence of the :confval:`html_logo` file, check
+* PR#211: When checking for existence of the `html_logo` file, check
the full relative path and not the basename.
* PR#212: Fix traceback with autodoc and ``__init__`` methods without docstring.
* PR#213: Fix a missing import in the setup command.
@@ -96,7 +251,7 @@ Bugs fixed
* #1370: Ignore "toctree" nodes in text writer, instead of raising.
* #1364: Fix 'make gettext' fails when the '.. todolist::' directive is present.
* #1367: Fix a change of PR#96 that break sphinx.util.docfields.Field.make_field
- interface/behavior for `item` argument usage.
+ interface/behavior for ``item`` argument usage.
Documentation
-------------
@@ -118,7 +273,7 @@ Bugs fixed
This was caused by a change for #1138.
* #1340: Can't search alphabetical words on the HTML quick search generated
with language='ja'.
-* #1319: Do not crash if the :confval:`html_logo` file does not exist.
+* #1319: Do not crash if the `html_logo` file does not exist.
* #603: Do not use the HTML-ized title for building the search index (that
resulted in "literal" being found on every page with a literal in the
title).
@@ -135,7 +290,7 @@ Bugs fixed
if they contain uppercase letters.
* #923: Take the entire LaTeX document into account when caching
pngmath-generated images. This rebuilds them correctly when
- :confval:`pngmath_latex_preamble` changes.
+ `pngmath_latex_preamble` changes.
* #901: Emit a warning when using docutils' new "math" markup without a Sphinx
math extension active.
* #845: In code blocks, when the selected lexer fails, display line numbers
@@ -152,14 +307,14 @@ Bugs fixed
* #1155: Fix autodocumenting C-defined methods as attributes in Python 3.
* #1233: Allow finding both Python classes and exceptions with the "class" and
"exc" roles in intersphinx.
-* #1198: Allow "image" for the "figwidth" option of the :rst:dir:`figure`
+* #1198: Allow "image" for the "figwidth" option of the :dudir:`figure`
directive as documented by docutils.
* #1152: Fix pycode parsing errors of Python 3 code by including two grammar
versions for Python 2 and 3, and loading the appropriate version for the
running Python version.
* #1017: Be helpful and tell the user when the argument to :rst:dir:`option`
does not match the required format.
-* #1345: Fix two bugs with :confval:`nitpick_ignore`; now you don't have to
+* #1345: Fix two bugs with `nitpick_ignore`; now you don't have to
remove the store environment for changes to have effect.
* #1072: In the JS search, fix issues searching for upper-cased words by
lowercasing words before stemming.
@@ -182,8 +337,8 @@ Bugs fixed
* #1300: Fix references not working in translated documents in some instances.
* #1283: Fix a bug in the detection of changed files that would try to access
doctrees of deleted documents.
-* #1330: Fix :confval:`exclude_patterns` behavior with subdirectories in the
- :confval:`html_static_path`.
+* #1330: Fix `exclude_patterns` behavior with subdirectories in the
+ `html_static_path`.
* #1323: Fix emitting empty ``<ul>`` tags in the HTML writer, which is not
valid HTML.
* #1147: Don't emit a sidebar search box in the "singlehtml" builder.
@@ -215,7 +370,7 @@ Bugs fixed
* Restore ``versionmodified`` CSS class for versionadded/changed and deprecated
directives.
-* PR#181: Fix `html_theme_path=['.']` is a trigger of rebuild all documents
+* PR#181: Fix ``html_theme_path = ['.']`` is a trigger of rebuild all documents
always (This change keeps the current "theme changes cause a rebuild"
feature).
@@ -282,7 +437,7 @@ Features added
* Support docutils.conf 'writers' and 'html4css1 writer' section in the HTML
writer. The latex, manpage and texinfo writers also support their respective
'writers' sections.
-* The new :confval:`html_extra_path` config value allows to specify directories
+* The new `html_extra_path` config value allows to specify directories
with files that should be copied directly to the HTML output directory.
* Autodoc directives for module data and attributes now support an
``annotation`` option, so that the default display of the data/attribute
@@ -353,10 +508,10 @@ Incompatible changes
* Removed ``sphinx.util.compat.directive_dwim()`` and
``sphinx.roles.xfileref_role()`` which were deprecated since version 1.0.
-* PR#122: the files given in :confval:`latex_additional_files` now override TeX
+* PR#122: the files given in `latex_additional_files` now override TeX
files included by Sphinx, such as ``sphinx.sty``.
-* PR#124: the node generated by :rst:dir:`versionadded`,
- :rst:dir:`versionchanged` and :rst:dir:`deprecated` directives now includes
+* PR#124: the node generated by `versionadded`,
+ `versionchanged` and `deprecated` directives now includes
all added markup (such as "New in version X") as child nodes, and no
additional text must be generated by writers.
* PR#99: the :rst:dir:`seealso` directive now generates admonition nodes instead
@@ -410,7 +565,7 @@ Features added
asterisks ("*").
- The default value for the ``paragraphindent`` has been changed from 2 to 0
meaning that paragraphs are no longer indented by default.
- - #1110: A new configuration value :confval:`texinfo_no_detailmenu` has been
+ - #1110: A new configuration value `texinfo_no_detailmenu` has been
added for controlling whether a ``@detailmenu`` is added in the "Top"
node's menu.
- Detailed menus are no longer created except for the "Top" node.
@@ -419,18 +574,18 @@ Features added
* LaTeX builder:
- - PR#115: Add ``'transition'`` item in :confval:`latex_elements` for
+ - PR#115: Add ``'transition'`` item in `latex_elements` for
customizing how transitions are displayed. Thanks to Jeff Klukas.
- PR#114: The LaTeX writer now includes the "cmap" package by default. The
- ``'cmappkg'`` item in :confval:`latex_elements` can be used to control this.
+ ``'cmappkg'`` item in `latex_elements` can be used to control this.
Thanks to Dmitry Shachnev.
- - The ``'fontpkg'`` item in :confval:`latex_elements` now defaults to ``''``
- when the :confval:`language` uses the Cyrillic script. Suggested by Dmitry
+ - The ``'fontpkg'`` item in `latex_elements` now defaults to ``''``
+ when the `language` uses the Cyrillic script. Suggested by Dmitry
Shachnev.
- - The :confval:`latex_documents`, :confval:`texinfo_documents`, and
- :confval:`man_pages` configuration values will be set to default values based
+ - The `latex_documents`, `texinfo_documents`, and
+ `man_pages` configuration values will be set to default values based
on the :confval:`master_doc` if not explicitly set in :file:`conf.py`.
- Previously, if these values were not set, no output would be genereted by
+ Previously, if these values were not set, no output would be generated by
their respective builders.
* Internationalization:
@@ -446,13 +601,13 @@ Features added
- Added the Docutils-native XML and pseudo-XML builders. See
:class:`XMLBuilder` and :class:`PseudoXMLBuilder`.
- PR#45: The linkcheck builder now checks ``#anchor``\ s for existence.
- - PR#123, #1106: Add :confval:`epub_use_index` configuration value. If
- provided, it will be used instead of :confval:`html_use_index` for epub
+ - PR#123, #1106: Add `epub_use_index` configuration value. If
+ provided, it will be used instead of `html_use_index` for epub
builder.
- - PR#126: Add :confval:`epub_tocscope` configuration value. The setting
+ - PR#126: Add `epub_tocscope` configuration value. The setting
controls the generation of the epub toc. The user can now also include
hidden toc entries.
- - PR#112: Add :confval:`epub_show_urls` configuration value.
+ - PR#112: Add `epub_show_urls` configuration value.
* Extensions:
@@ -471,7 +626,7 @@ Features added
- sphinx-build now provides more specific error messages when called with
invalid options or arguments.
- sphinx-build now has a verbose option :option:`-v` which can be repeated for
- greater effect. A single occurrance provides a slightly more verbose output
+ greater effect. A single occurrence provides a slightly more verbose output
than normal. Two or more occurrences of this option provides more detailed
output which may be useful for debugging.
@@ -520,7 +675,7 @@ Bugs fixed
* #1127: Fix traceback when autodoc tries to tokenize a non-Python file.
* #1126: Fix double-hyphen to en-dash conversion in wrong places such as
command-line option names in LaTeX.
-* #1123: Allow whitespaces in filenames given to :rst:dir:`literalinclude`.
+* #1123: Allow whitespaces in filenames given to `literalinclude`.
* #1120: Added improvements about i18n for themes "basic", "haiku" and
"scrolls" that Sphinx built-in. Thanks to Leonardo J. Caballero G.
* #1118: Updated Spanish translation. Thanks to Leonardo J. Caballero G.
@@ -528,7 +683,7 @@ Bugs fixed
* #1112: Avoid duplicate download files when referenced from documents in
different ways (absolute/relative).
* #1111: Fix failure to find uppercase words in search when
- :confval:`html_search_language` is 'ja'. Thanks to Tomo Saito.
+ `html_search_language` is 'ja'. Thanks to Tomo Saito.
* #1108: The text writer now correctly numbers enumerated lists with
non-default start values (based on patch by Ewan Edwards).
* #1102: Support multi-context "with" statements in autodoc.
@@ -593,7 +748,7 @@ Release 1.1.3 (Mar 10, 2012)
* #860: Do not crash when encountering invalid doctest examples, just
emit a warning.
-* #864: Fix crash with some settings of :confval:`modindex_common_prefix`.
+* #864: Fix crash with some settings of `modindex_common_prefix`.
* #862: Fix handling of ``-D`` and ``-A`` options on Python 3.
@@ -657,7 +812,7 @@ Release 1.1 (Oct 9, 2011)
Incompatible changes
--------------------
-* The :rst:dir:`py:module` directive doesn't output its ``platform`` option
+* The `py:module` directive doesn't output its ``platform`` option
value anymore. (It was the only thing that the directive did output, and
therefore quite inconsistent.)
@@ -693,7 +848,7 @@ Features added
:rst:dir:`toctree`\'s ``numbered`` option.
- #586: Implemented improved :rst:dir:`glossary` markup which allows
multiple terms per definition.
- - #478: Added :rst:dir:`py:decorator` directive to describe decorators.
+ - #478: Added `py:decorator` directive to describe decorators.
- C++ domain now supports array definitions.
- C++ domain now supports doc fields (``:param x:`` inside directives).
- Section headings in :rst:dir:`only` directives are now correctly
@@ -704,7 +859,7 @@ Features added
* HTML builder:
- Added ``pyramid`` theme.
- - #559: :confval:`html_add_permalinks` is now a string giving the
+ - #559: `html_add_permalinks` is now a string giving the
text to display in permalinks.
- #259: HTML table rows now have even/odd CSS classes to enable
"Zebra styling".
@@ -712,26 +867,26 @@ Features added
* Other builders:
- - #516: Added new value of the :confval:`latex_show_urls` option to
+ - #516: Added new value of the `latex_show_urls` option to
show the URLs in footnotes.
- - #209: Added :confval:`text_newlines` and :confval:`text_sectionchars`
+ - #209: Added `text_newlines` and `text_sectionchars`
config values.
- - Added :confval:`man_show_urls` config value.
+ - Added `man_show_urls` config value.
- #472: linkcheck builder: Check links in parallel, use HTTP HEAD
requests and allow configuring the timeout. New config values:
- :confval:`linkcheck_timeout` and :confval:`linkcheck_workers`.
- - #521: Added :confval:`linkcheck_ignore` config value.
+ `linkcheck_timeout` and `linkcheck_workers`.
+ - #521: Added `linkcheck_ignore` config value.
- #28: Support row/colspans in tables in the LaTeX builder.
* Configuration and extensibility:
- - #537: Added :confval:`nitpick_ignore`.
+ - #537: Added `nitpick_ignore`.
- #306: Added :event:`env-get-outdated` event.
- :meth:`.Application.add_stylesheet` now accepts full URIs.
* Autodoc:
- - #564: Add :confval:`autodoc_docstring_signature`. When enabled (the
+ - #564: Add `autodoc_docstring_signature`. When enabled (the
default), autodoc retrieves the signature from the first line of the
docstring, if it is found there.
- #176: Provide ``private-members`` option for autodoc directives.
@@ -749,12 +904,12 @@ Features added
- Added ``inline`` option to graphviz directives, and fixed the
default (block-style) in LaTeX output.
- #590: Added ``caption`` option to graphviz directives.
- - #553: Added :rst:dir:`testcleanup` blocks in the doctest extension.
- - #594: :confval:`trim_doctest_flags` now also removes ``<BLANKLINE>``
+ - #553: Added `testcleanup` blocks in the doctest extension.
+ - #594: `trim_doctest_flags` now also removes ``<BLANKLINE>``
indicators.
- #367: Added automatic exclusion of hidden members in inheritance
diagrams, and an option to selectively enable it.
- - Added :confval:`pngmath_add_tooltips`.
+ - Added `pngmath_add_tooltips`.
- The math extension displaymath directives now support ``name`` in
addition to ``label`` for giving the equation label, for compatibility
with Docutils.
@@ -827,7 +982,7 @@ Release 1.0.8 (Sep 23, 2011)
* #669: Respect the ``noindex`` flag option in py:module directives.
* #675: Fix IndexErrors when including nonexisting lines with
- :rst:dir:`literalinclude`.
+ `literalinclude`.
* #676: Respect custom function/method parameter separator strings.
@@ -910,7 +1065,7 @@ Release 1.0.6 (Jan 04, 2011)
* #570: Try decoding ``-D`` and ``-A`` command-line arguments with
the locale's preferred encoding.
-* #528: Observe :confval:`locale_dirs` when looking for the JS
+* #528: Observe `locale_dirs` when looking for the JS
translations file.
* #574: Add special code for better support of Japanese documents
@@ -931,7 +1086,7 @@ Release 1.0.6 (Jan 04, 2011)
* #515: Fix tracebacks in the viewcode extension for Python objects
that do not have a valid signature.
-* Fix strange reportings of line numbers for warnings generated from
+* Fix strange reports of line numbers for warnings generated from
autodoc-included docstrings, due to different behavior depending
on docutils version.
@@ -1083,51 +1238,51 @@ Features added
- Added a "nitpicky" mode that emits warnings for all missing
references. It is activated by the :option:`-n` command-line switch
- or the :confval:`nitpicky` config value.
+ or the `nitpicky` config value.
- Added ``latexpdf`` target in quickstart Makefile.
* Markup:
- - The :rst:role:`menuselection` and :rst:role:`guilabel` roles now
+ - The `menuselection` and `guilabel` roles now
support ampersand accelerators.
- New more compact doc field syntax is now recognized: ``:param type
name: description``.
- - Added ``tab-width`` option to :rst:dir:`literalinclude` directive.
+ - Added ``tab-width`` option to `literalinclude` directive.
- Added ``titlesonly`` option to :rst:dir:`toctree` directive.
- Added the ``prepend`` and ``append`` options to the
- :rst:dir:`literalinclude` directive.
+ `literalinclude` directive.
- #284: All docinfo metadata is now put into the document metadata, not
just the author.
- - The :rst:role:`ref` role can now also reference tables by caption.
- - The :rst:dir:`include` directive now supports absolute paths, which
+ - The `ref` role can now also reference tables by caption.
+ - The :dudir:`include` directive now supports absolute paths, which
are interpreted as relative to the source directory.
- In the Python domain, references like ``:func:`.name``` now look for
matching names with any prefix if no direct match is found.
* Configuration:
- - Added :confval:`rst_prolog` config value.
- - Added :confval:`html_secnumber_suffix` config value to control
+ - Added `rst_prolog` config value.
+ - Added `html_secnumber_suffix` config value to control
section numbering format.
- - Added :confval:`html_compact_lists` config value to control
+ - Added `html_compact_lists` config value to control
docutils' compact lists feature.
- - The :confval:`html_sidebars` config value can now contain patterns
+ - The `html_sidebars` config value can now contain patterns
as keys, and the values can be lists that explicitly select which
sidebar templates should be rendered. That means that the builtin
sidebar contents can be included only selectively.
- - :confval:`html_static_path` can now contain single file entries.
- - The new universal config value :confval:`exclude_patterns` makes the
- old :confval:`unused_docs`, :confval:`exclude_trees` and
- :confval:`exclude_dirnames` obsolete.
- - Added :confval:`html_output_encoding` config value.
- - Added the :confval:`latex_docclass` config value and made the
+ - `html_static_path` can now contain single file entries.
+ - The new universal config value `exclude_patterns` makes the
+ old ``unused_docs``, ``exclude_trees`` and
+ ``exclude_dirnames`` obsolete.
+ - Added `html_output_encoding` config value.
+ - Added the `latex_docclass` config value and made the
"twoside" documentclass option overridable by "oneside".
- - Added the :confval:`trim_doctest_flags` config value, which is true
+ - Added the `trim_doctest_flags` config value, which is true
by default.
- - Added :confval:`html_show_copyright` config value.
- - Added :confval:`latex_show_pagerefs` and :confval:`latex_show_urls`
+ - Added `html_show_copyright` config value.
+ - Added `latex_show_pagerefs` and `latex_show_urls`
config values.
- - The behavior of :confval:`html_file_suffix` changed slightly: the
+ - The behavior of `html_file_suffix` changed slightly: the
empty string now means "no suffix" instead of "default suffix", use
``None`` for "default suffix".
@@ -1169,7 +1324,7 @@ Features added
* Extension API:
- Added :event:`html-collect-pages`.
- - Added :confval:`needs_sphinx` config value and
+ - Added `needs_sphinx` config value and
:meth:`~sphinx.application.Sphinx.require_sphinx` application API
method.
- #200: Added :meth:`~sphinx.application.Sphinx.add_stylesheet`
@@ -1181,7 +1336,7 @@ Features added
- Added the :mod:`~sphinx.ext.extlinks` extension.
- Added support for source ordering of members in autodoc, with
``autodoc_member_order = 'bysource'``.
- - Added :confval:`autodoc_default_flags` config value, which can be
+ - Added `autodoc_default_flags` config value, which can be
used to select default flags for all autodoc directives.
- Added a way for intersphinx to refer to named labels in other
projects, and to specify the project you want to link to.
@@ -1191,7 +1346,7 @@ Features added
extension, thanks to Pauli Virtanen.
- #309: The :mod:`~sphinx.ext.graphviz` extension can now output SVG
instead of PNG images, controlled by the
- :confval:`graphviz_output_format` config value.
+ `graphviz_output_format` config value.
- Added ``alt`` option to :rst:dir:`graphviz` extension directives.
- Added ``exclude`` argument to :func:`.autodoc.between`.