summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWillem <14mRh4X0r@gmail.com>2023-05-12 23:46:17 +0200
committerGitHub <noreply@github.com>2023-05-12 22:46:17 +0100
commitde6b18ac7de317030be4344ea7a9d553c423ffcf (patch)
tree1047c5c009c6f6dc0d59b143b747514e1b92c054
parentdb546189ce1d2a345f4399367ced6ecdd538be5d (diff)
downloadsphinx-git-de6b18ac7de317030be4344ea7a9d553c423ffcf.tar.gz
Remove remaining references to the setuptools integration (#11418)7.0.x
Co-authored-by: Adam Turner <9087854+AA-Turner@users.noreply.github.com>
-rw-r--r--CHANGES4
-rw-r--r--pyproject.toml5
2 files changed, 4 insertions, 5 deletions
diff --git a/CHANGES b/CHANGES
index 631ec3b7b..2ece2cac6 100644
--- a/CHANGES
+++ b/CHANGES
@@ -20,6 +20,10 @@ Features added
Bugs fixed
----------
+* #11418: Clean up remaining references to ``sphinx.setup_command``
+ following the removal of support for setuptools.
+ Patch by Willem Mulder.
+
Testing
--------
diff --git a/pyproject.toml b/pyproject.toml
index 7b48d4efe..cd21fb6bc 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -105,9 +105,6 @@ sphinx-quickstart = "sphinx.cmd.quickstart:main"
sphinx-apidoc = "sphinx.ext.apidoc:main"
sphinx-autogen = "sphinx.ext.autosummary.generate:main"
-[project.entry-points."distutils.commands"]
-build_sphinx = 'sphinx.setup_command:BuildDoc'
-
[tool.flit.module]
name = "sphinx"
@@ -344,7 +341,6 @@ module = [
"sphinx.ext.napoleon.docstring",
"sphinx.pycode.parser",
"sphinx.registry",
- "sphinx.setup_command",
"sphinx.testing.util",
"sphinx.transforms.i18n",
"sphinx.transforms.post_transforms.images",
@@ -391,7 +387,6 @@ filterwarnings = [
]
markers = [
"apidoc",
- "setup_command",
]
testpaths = ["tests"]