summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Turner <9087854+aa-turner@users.noreply.github.com>2023-05-12 22:57:09 +0100
committerAdam Turner <9087854+aa-turner@users.noreply.github.com>2023-05-12 22:57:09 +0100
commit343e14939824bcb8014ac8aadaf5a159c85962d3 (patch)
treeec5ac0c677f39253c9bef3a922a05a37f2b81d97
parent749af9561e4f142fef64a0daab9d63054985a5f0 (diff)
parentd48cc783b6e48b99cbbcf5462f44c59a4ed78e6a (diff)
downloadsphinx-git-343e14939824bcb8014ac8aadaf5a159c85962d3.tar.gz
Merge branch '7.0.x'
# Conflicts: # CHANGES # sphinx/__init__.py
-rw-r--r--CHANGES21
-rw-r--r--pyproject.toml5
2 files changed, 17 insertions, 9 deletions
diff --git a/CHANGES b/CHANGES
index 795e63de7..e66f11cbf 100644
--- a/CHANGES
+++ b/CHANGES
@@ -4,10 +4,6 @@ Release 7.1.0 (in development)
Dependencies
------------
-* #11411: Support `Docutils 0.20`_. Patch by Adam Turner.
-
-.. _Docutils 0.20: https://docutils.sourceforge.io/RELEASE-NOTES.html#release-0-20-2023-05-04
-
Incompatible changes
--------------------
@@ -42,6 +38,23 @@ Bugs fixed
Testing
--------
+Release 7.0.1 (released May 12, 2023)
+=====================================
+
+Dependencies
+------------
+
+* #11411: Support `Docutils 0.20`_. Patch by Adam Turner.
+
+.. _Docutils 0.20: https://docutils.sourceforge.io/RELEASE-NOTES.html#release-0-20-2023-05-04
+
+Bugs fixed
+----------
+
+* #11418: Clean up remaining references to ``sphinx.setup_command``
+ following the removal of support for setuptools.
+ Patch by Willem Mulder.
+
Release 7.0.0 (released Apr 29, 2023)
=====================================
diff --git a/pyproject.toml b/pyproject.toml
index 7b48d4efe..cd21fb6bc 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -105,9 +105,6 @@ sphinx-quickstart = "sphinx.cmd.quickstart:main"
sphinx-apidoc = "sphinx.ext.apidoc:main"
sphinx-autogen = "sphinx.ext.autosummary.generate:main"
-[project.entry-points."distutils.commands"]
-build_sphinx = 'sphinx.setup_command:BuildDoc'
-
[tool.flit.module]
name = "sphinx"
@@ -344,7 +341,6 @@ module = [
"sphinx.ext.napoleon.docstring",
"sphinx.pycode.parser",
"sphinx.registry",
- "sphinx.setup_command",
"sphinx.testing.util",
"sphinx.transforms.i18n",
"sphinx.transforms.post_transforms.images",
@@ -391,7 +387,6 @@ filterwarnings = [
]
markers = [
"apidoc",
- "setup_command",
]
testpaths = ["tests"]