summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYoshiki Shibukawa <yshibukawa@ngmoco.com>2014-07-16 19:03:46 +0900
committerYoshiki Shibukawa <yshibukawa@ngmoco.com>2014-07-16 19:03:46 +0900
commitf0d81ce1606d685029302ea073b59d9437d12569 (patch)
treea7de3542914a943cf15dfd91751b9de2fa03e604
parentc697d308906ea526cb56778b3856ad908b958d94 (diff)
downloadsnowballstemmer-f0d81ce1606d685029302ea073b59d9437d12569.tar.gz
update configs, readme, sample minor bug
-rw-r--r--README.rst6
-rw-r--r--sample/testapp.py2
-rw-r--r--setup.py3
3 files changed, 9 insertions, 2 deletions
diff --git a/README.rst b/README.rst
index d89da48..5346aab 100644
--- a/README.rst
+++ b/README.rst
@@ -76,6 +76,12 @@ Usage::
$ python testapp.py English "sentences... "
+Thanks
+-------
+
+* Original Snowball authors
+* Emil Stenström
+
License
-------
diff --git a/sample/testapp.py b/sample/testapp.py
index 1566134..17757d6 100644
--- a/sample/testapp.py
+++ b/sample/testapp.py
@@ -8,7 +8,7 @@ def usage():
def main():
argv = sys.argv
- if len(argv) < 1:
+ if len(argv) < 2:
usage()
return
algorithm = 'english'
diff --git a/setup.py b/setup.py
index 02eb447..25c3fb6 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
from distutils.core import setup
setup(name='snowballstemmer',
- version='1.1.0',
+ version='1.2.0',
description='This package provides 16 stemmer algorithms (15 + Poerter English stemmer) generated from Snowball algorithms.',
long_description='''
It includes following language algorithms:
@@ -59,6 +59,7 @@ it to accelerate.
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Database',
'Topic :: Internet :: WWW/HTTP :: Indexing/Search',