summaryrefslogtreecommitdiff
path: root/doc
diff options
context:
space:
mode:
authorSebastian Thiel <byronimo@gmail.com>2011-06-13 21:07:03 +0200
committerSebastian Thiel <byronimo@gmail.com>2011-06-13 22:12:13 +0200
commit78cdb214fb6273169433fa662ad630afc26eb36a (patch)
treea677d569d4e4f58c7fac0ee8a12571b4bd9184a3 /doc
parent65dacbbd74a46698932cccdcab54f7558d1da169 (diff)
downloadsmmap-78cdb214fb6273169433fa662ad630afc26eb36a.tar.gz
Wrote introduction, readme.rst now points to the introduction page to keep things consistent
Diffstat (limited to 'doc')
-rw-r--r--doc/source/api.rst42
-rw-r--r--doc/source/index.rst3
-rw-r--r--doc/source/intro.rst82
3 files changed, 127 insertions, 0 deletions
diff --git a/doc/source/api.rst b/doc/source/api.rst
new file mode 100644
index 0000000..7e2854a
--- /dev/null
+++ b/doc/source/api.rst
@@ -0,0 +1,42 @@
+.. _api-label:
+
+#############
+API Reference
+#############
+
+****************
+smmap.mman
+****************
+
+.. automodule:: smmap.mman
+ :members:
+ :undoc-members:
+
+****************
+smmap.buf
+****************
+
+.. automodule:: smmap.buf
+ :members:
+ :undoc-members:
+
+****************
+smmap.exc
+****************
+
+.. automodule:: smmap.exc
+ :members:
+ :undoc-members:
+
+****************
+smmap.util
+****************
+
+.. automodule:: smmap.util
+ :members:
+ :undoc-members:
+
+
+
+
+
diff --git a/doc/source/index.rst b/doc/source/index.rst
index cb03044..d25ef82 100644
--- a/doc/source/index.rst
+++ b/doc/source/index.rst
@@ -12,6 +12,9 @@ Contents:
.. toctree::
:maxdepth: 2
+ intro
+ tutorial
+ api
changes
Indices and tables
diff --git a/doc/source/intro.rst b/doc/source/intro.rst
new file mode 100644
index 0000000..b35e785
--- /dev/null
+++ b/doc/source/intro.rst
@@ -0,0 +1,82 @@
+###########
+Motivation
+###########
+When reading from many possibly large files in a fashion similar to random access, it is usually the fastest and most efficient to use memory maps.
+
+Although memory maps have many advantages, they represent a very limited system resource as every map uses one file descriptor, whose amount is limited per process. On 32 bit systems, the amount of memory you can have mapped at a time is naturally limited to theoretical 4GB of memory, which may not be enough for some applications.
+
+########
+Overview
+########
+
+Smmap wraps an interface around mmap and tracks the mapped files as well as the amount of clients who use it. If the system runs out of resources, or if a memory limit is reached, it will automatically unload unused maps to allow continued operation.
+
+To allow processing large files even on 32 bit systems, it allows only portions of the file to be mapped. Once the user reads beyond the mapped region, smmap will automatically map the next required region, unloading unused regions using a LRU algorithm.
+
+The interface also works around the missing offset parameter in python implementations up to python 2.5.
+
+Although the library can be used most efficiently with its native interface, a Buffer implementation is provided to hide these details behind a simple string-like interface.
+
+For performance critical 64 bit applications, a simplified version of memory mapping is provided which always maps the whole file, but still provides the benefit of unloading unused mappings on demand.
+
+#############
+Prerequisites
+#############
+* Python 2.4, 2.5 or 2.6
+* OSX, Windows or Linux
+
+The package was tested on all of the previously mentioned configurations.
+
+###########
+Limitations
+###########
+* The memory access is read-only by design.
+* In python below 2.6, memory maps will be created in compatibility mode which works, but creates inefficient memory mappings as they always start at offset 0.
+* It wasn't tested on python 2.7 and 3.x.
+
+###############
+Getting Started
+###############
+It is advised to have a look at the :ref:`Usage Guide <tutorial-label>` for a brief introduction on the different database implementations.
+
+################
+Installing smmap
+################
+Its easiest to install smmap using the *easy_install* or *pip* program, which is part of the `setuptools`_ or `pip`_ respectively::
+
+ $ easy_install smmap
+ # or
+ $ pip install smmap
+
+As the command will install smmap in your respective python distribution, you will most likely need root permissions to authorize the required changes.
+
+If you have downloaded the source archive, the package can be installed by running the ``setup.py`` script::
+
+ $ python setup.py install
+
+##################
+Homepage and Links
+##################
+The project is home on github at `https://github.com/Byron/smmap <https://github.com/Byron/smmap>`_.
+
+The latest source can be cloned from github as well:
+
+ * git://github.com/gitpython-developers/smmap.git
+
+
+For support, please use the git-python mailing list:
+
+ * http://groups.google.com/group/git-python
+
+
+Issues can be filed on github:
+
+ * https://github.com/Byron/smmap/issues
+
+###################
+License Information
+###################
+*smmap* is licensed under the New BSD License.
+
+.. _setuptools: http://peak.telecommunity.com/DevCenter/setuptools
+.. _pip: http://www.pip-installer.org/en/latest/