summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2022-11-16 18:06:32 +0200
committerHugo van Kemenade <hugovk@users.noreply.github.com>2022-11-16 18:06:32 +0200
commit0370014ee74a0f4480127932a78f177f6f433b9e (patch)
tree6ab5cae13002d0d9b7c4e07945827273dc3564f0
parenta8cdf46b26f2f7029d3749bc431e2b80fe28b04a (diff)
downloadsmmap-0370014ee74a0f4480127932a78f177f6f433b9e.tar.gz
Drop support for EOL Python 3.6
-rw-r--r--.github/workflows/pythonpackage.yml2
-rw-r--r--README.md2
-rw-r--r--doc/source/intro.rst2
-rwxr-xr-xsetup.py3
-rw-r--r--smmap/buf.py2
-rw-r--r--tox.ini2
6 files changed, 6 insertions, 7 deletions
diff --git a/.github/workflows/pythonpackage.yml b/.github/workflows/pythonpackage.yml
index d593fd0..9e2d881 100644
--- a/.github/workflows/pythonpackage.yml
+++ b/.github/workflows/pythonpackage.yml
@@ -15,7 +15,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: ["3.6", "3.7", "3.8", "3.9", "3.10", "3.11"]
+ python-version: ["3.7", "3.8", "3.9", "3.10", "3.11"]
steps:
- uses: actions/checkout@v3
diff --git a/README.md b/README.md
index f083dd0..e21f534 100644
--- a/README.md
+++ b/README.md
@@ -27,7 +27,7 @@ For performance critical 64 bit applications, a simplified version of memory map
## Prerequisites
-* Python 3.6+
+* Python 3.7+
* OSX, Windows or Linux
The package was tested on all of the previously mentioned configurations.
diff --git a/doc/source/intro.rst b/doc/source/intro.rst
index 3489b04..109fec2 100644
--- a/doc/source/intro.rst
+++ b/doc/source/intro.rst
@@ -20,7 +20,7 @@ For performance critical 64 bit applications, a simplified version of memory map
#############
Prerequisites
#############
-* Python 3.6+
+* Python 3.7+
* OSX, Windows or Linux
The package was tested on all of the previously mentioned configurations.
diff --git a/setup.py b/setup.py
index 9ab8a7f..1df3b62 100755
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,7 @@ setup(
license="BSD",
packages=find_packages(),
zip_safe=True,
- python_requires=">=3.6",
+ python_requires=">=3.7",
classifiers=[
"Development Status :: 5 - Production/Stable",
"Environment :: Console",
@@ -38,7 +38,6 @@ setup(
"Operating System :: MacOS :: MacOS X",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
diff --git a/smmap/buf.py b/smmap/buf.py
index ad27b69..731b064 100644
--- a/smmap/buf.py
+++ b/smmap/buf.py
@@ -93,7 +93,7 @@ class SlidingWindowMapBuffer:
d = d.tobytes()
md.append(d)
# END while there are bytes to read
- return bytes().join(md)
+ return b''.join(md)
# END fast or slow path
#{ Interface
diff --git a/tox.ini b/tox.ini
index 092c79d..810badd 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,7 +4,7 @@
# and then run "tox" from this directory.
[tox]
-envlist = flake8, py{36, 37, 38, 39, 310, 311}
+envlist = flake8, py{37, 38, 39, 310, 311}
[testenv]
commands = {envpython} -m pytest --cov smmap --cov-report xml {posargs}