summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYu-Jie Lin <livibetter@gmail.com>2016-12-28 14:17:26 +0800
committerYu-Jie Lin <livibetter@gmail.com>2016-12-28 14:17:26 +0800
commite531abd25cef524739f35c840af18891936c9df5 (patch)
tree32acfb2caa8f302c5f93be461fbc463c1ee69a90
parent039c16111c3bbb0cdd2627f1e6d2c5ae68f4256e (diff)
downloadsmartypants-git-e531abd25cef524739f35c840af18891936c9df5.tar.gz
do not build zip sdist
-rw-r--r--CHANGES.rst3
-rw-r--r--Makefile2
2 files changed, 4 insertions, 1 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index 6b7125a..dbd5416 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -67,6 +67,9 @@ Development
- do not build ``bdist_wininst --plat-name win32`` per
:pep:`527#bdist-dmg-bdist-msi-and-bdist-wininst`
+ - do not make ``sdist --format=zip``, it would get a duplicate warning on
+ PyPI
+
+ test packages build in ``test_setup`` target
* rename target ``install_test`` to ``test_setup``
diff --git a/Makefile b/Makefile
index 7789ef2..15c685b 100644
--- a/Makefile
+++ b/Makefile
@@ -8,7 +8,7 @@ PY2_CMD=python2
PY3_CMD=python3
INSTALL_TEST_DIR=/tmp/$(PACKAGE)_install_test
-BUILD_CMD=./setup.py sdist --formats gztar,zip bdist_wheel
+BUILD_CMD=./setup.py sdist --formats gztar bdist_wheel
DOC_FILES = CHANGES.rst COPYING docs/conf.py $(wildcard docs/*.rst)