summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYu-Jie Lin <livibetter@gmail.com>2016-12-28 13:50:55 +0800
committerYu-Jie Lin <livibetter@gmail.com>2016-12-28 13:50:55 +0800
commitd9a25abd73eaf809f836f240d7874eacd6af3fdc (patch)
tree498a86d833475e02d1958c1fd8569248bfa9ff63
parentaae017cddd262f51779d296f578b41d6887aa360 (diff)
downloadsmartypants-git-d9a25abd73eaf809f836f240d7874eacd6af3fdc.tar.gz
drop bdist_wininst build per PEP 527 [1]v2.0.0dev
[1] https://www.python.org/dev/peps/pep-0527/#bdist-dmg-bdist-msi-and-bdist-wininst
-rw-r--r--CHANGES.rst3
-rw-r--r--Makefile4
2 files changed, 5 insertions, 2 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index 195f75c..6b7125a 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -64,6 +64,9 @@ Development
* Makefile
+ - do not build ``bdist_wininst --plat-name win32`` per
+ :pep:`527#bdist-dmg-bdist-msi-and-bdist-wininst`
+
+ test packages build in ``test_setup`` target
* rename target ``install_test`` to ``test_setup``
diff --git a/Makefile b/Makefile
index 7b43989..7789ef2 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-# Copyright (c) 2013, 2014 Yu-Jie Lin
+# Copyright (c) 2013, 2014, 2016 Yu-Jie Lin
# Licensed under the BSD License, for detailed license information, see COPYING
PACKAGE=smartypants
@@ -8,7 +8,7 @@ PY2_CMD=python2
PY3_CMD=python3
INSTALL_TEST_DIR=/tmp/$(PACKAGE)_install_test
-BUILD_CMD=./setup.py sdist --formats gztar,zip bdist_wheel bdist_wininst --plat-name win32
+BUILD_CMD=./setup.py sdist --formats gztar,zip bdist_wheel
DOC_FILES = CHANGES.rst COPYING docs/conf.py $(wildcard docs/*.rst)