summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 9 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index 338905e..25ae215 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@
"""This library brings functools.singledispatch from Python 3.4 to Python 2.6-3.3."""
# Copyright (C) 2013 by Łukasz Langa
-#
+#
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
# in the Software without restriction, including without limitation the rights
@@ -26,13 +26,7 @@
import os
import sys
import codecs
-from setuptools import setup, find_packages
-
-PY3 = sys.version_info[0] == 3
-
-if not PY3:
- reload(sys)
- sys.setdefaultencoding('utf8')
+from setuptools import setup
with codecs.open(
os.path.join(os.path.dirname(__file__), 'README.rst'), 'r', 'utf8',
@@ -41,9 +35,13 @@ with codecs.open(
# We let it die a horrible tracebacking death if reading the file fails.
# We couldn't sensibly recover anyway: we need the long description.
+install_requires = ['six']
+if sys.version_info[:2] < (2, 7):
+ install_requires.append('ordereddict')
+
setup (
name = 'singledispatch',
- version = '3.4.0.2',
+ version = '3.4.0.3',
author = 'Łukasz Langa',
author_email = 'lukasz@langa.pl',
description = __doc__,
@@ -56,9 +54,7 @@ setup (
license = 'MIT',
py_modules = ('singledispatch', 'singledispatch_helpers'),
zip_safe = True,
- install_requires = [
- 'six',
- ],
+ install_requires = install_requires,
classifiers = [
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
@@ -72,6 +68,7 @@ setup (
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
'Topic :: Software Development :: Libraries',
'Topic :: Software Development :: Libraries :: Python Modules',
]