summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author?ukasz Langa <lukasz@langa.pl>2014-03-18 14:01:22 -0700
committer?ukasz Langa <lukasz@langa.pl>2014-03-18 14:01:22 -0700
commit92175ba65602a03086d2b1f770f45d88af93fc3e (patch)
treef2bd53d1cfe597a528901cfa1b519ea6229fad37
parentf53a92aca9f59e65930f3c8710b381e431ef219e (diff)
downloadsingledispatch-3.4.0.3.tar.gz
Updated setup.py and Tox to include Python 3.43.4.0.3
-rw-r--r--README.rst9
-rw-r--r--setup.py9
-rw-r--r--tox.ini2
3 files changed, 14 insertions, 6 deletions
diff --git a/README.rst b/README.rst
index 39e35c7..98d4cae 100644
--- a/README.rst
+++ b/README.rst
@@ -2,6 +2,9 @@
singledispatch
==============
+.. image:: https://secure.travis-ci.org/ambv/singledispatch.png
+ :target: https://secure.travis-ci.org/ambv/singledispatch
+
`PEP 443 <http://www.python.org/dev/peps/pep-0443/>`_ proposed to expose
a mechanism in the ``functools`` standard library module in Python 3.4
that provides a simple form of generic programming known as
@@ -145,6 +148,12 @@ members of the core CPython team:
Change Log
----------
+3.4.0.3
+~~~~~~~
+
+Should now install flawlessly on PyPy as well. Thanks to Ryan Petrello
+for finding and fixing the ``setup.py`` issue.
+
3.4.0.2
~~~~~~~
diff --git a/setup.py b/setup.py
index 6fb8f98..25ae215 100644
--- a/setup.py
+++ b/setup.py
@@ -4,7 +4,7 @@
"""This library brings functools.singledispatch from Python 3.4 to Python 2.6-3.3."""
# Copyright (C) 2013 by Łukasz Langa
-#
+#
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
# in the Software without restriction, including without limitation the rights
@@ -26,9 +26,7 @@
import os
import sys
import codecs
-from setuptools import setup, find_packages
-
-PY3 = sys.version_info[0] == 3
+from setuptools import setup
with codecs.open(
os.path.join(os.path.dirname(__file__), 'README.rst'), 'r', 'utf8',
@@ -43,7 +41,7 @@ if sys.version_info[:2] < (2, 7):
setup (
name = 'singledispatch',
- version = '3.4.0.2',
+ version = '3.4.0.3',
author = 'Łukasz Langa',
author_email = 'lukasz@langa.pl',
description = __doc__,
@@ -70,6 +68,7 @@ setup (
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
'Topic :: Software Development :: Libraries',
'Topic :: Software Development :: Libraries :: Python Modules',
]
diff --git a/tox.ini b/tox.ini
index 3026029..1f6ddaa 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py26,py27,py32,py33,pypy
+envlist = py26,py27,py32,py33,py34,pypy
[testenv]
commands =