summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/python-tests.yml8
-rw-r--r--CHANGELOG.rst5
2 files changed, 10 insertions, 3 deletions
diff --git a/.github/workflows/python-tests.yml b/.github/workflows/python-tests.yml
index 4963733..6c3d172 100644
--- a/.github/workflows/python-tests.yml
+++ b/.github/workflows/python-tests.yml
@@ -59,7 +59,8 @@ jobs:
fail-fast: false
matrix:
python_version: [ '2.7', '3.5', '3.6', '3.7', '3.8', 'pypy2', 'pypy3' ]
- name: check self install - Python ${{ matrix.python_version }}
+ installer: ["pip install", easy_install]
+ name: check self install - Python ${{ matrix.python_version }} via ${{ matrix.installer }}
steps:
- uses: actions/checkout@v1
- name: Setup python
@@ -69,10 +70,11 @@ jobs:
architecture: x64
# self install testing needs some clarity
# so its being executed without any other tools running
- - run: pip install -U setuptools
+ # setuptools smaller 52 is needed too di easy_install
+ - run: pip install -U "setuptools<52"
- run: python setup.py egg_info
- run: python setup.py sdist
- - run: easy_install dist/*
+ - run: ${{ matrix.installer }} dist/*
- run: python testing/check_self_install.py
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
index 7c68389..41a1ff0 100644
--- a/CHANGELOG.rst
+++ b/CHANGELOG.rst
@@ -1,3 +1,8 @@
+v5.0.2
+======
+
+* fix #415: use git for matching prefixes to support the windows situation
+
v5.0.1
======