summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2014-04-07 20:32:17 +0200
committerRonny Pfannschmidt <opensource@ronnypfannschmidt.de>2014-04-07 20:32:17 +0200
commitdcb2f4dd6b9f58780a0a9da7f43ecbe395e0a0d0 (patch)
tree59654e84a89f15f5125dd0ba3787fb3cf0776f59
parent20d4573e47a68c99179ab56b0469d0cfe960eda1 (diff)
downloadsetuptools-scm-dcb2f4dd6b9f58780a0a9da7f43ecbe395e0a0d0.tar.gz
some docs
-rw-r--r--README.txt24
1 files changed, 17 insertions, 7 deletions
diff --git a/README.txt b/README.txt
index 7c97a78..6b57aa5 100644
--- a/README.txt
+++ b/README.txt
@@ -2,21 +2,31 @@ hgdistver
~~~~~~~~~
This module is a simple drop-in to support setup.py
-in mercurial based projects.
+in mercurial and git based projects.
Alternatively it can be a setup time requirement.
-Its supposed to generate version numbers from mercurials meta-data.
-It tries to use the current tag and
-falls back to the next reachable tagged ancestor and
-using the distance to it as .post marker.
+It extracts the last Tag as well as the distance to it in commits
+from the scm, and uses these to calculate a version number
+
+By default, it will increment the last component of the Version by one
+and append .dev{distance}
+in case the last component is .dev, the version will be unchanged
+
+Tis requires always using all components in tags (i.e. 2.0.0 instead of 2.0)
+to avoid misstakenly releasing higher version
+(i.e. 2.1.devX instead of 2.0.1.devX)
+
+
+
It uses 4 strategies to archive its task:
1. try to directly ask hg for the tag/distance
2. try to infer it from the `.hg_archival.txt` file
-3. try to use the cache file if it exists
-4. try to read the version from the 'PKG-INFO' file sdists contain (this is a nasty abuse)
+3. try to read the exact version the cache file if it exists
+4. try to read the exact version from the 'PKG-INFO' file
+ as generated by `setup.py sdists` (this is a nasty abuse)
The most simple usage is::