summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Barrois <raphael.barrois@polytechnique.org>2021-03-02 11:22:23 +0100
committerRaphaël Barrois <raphael.barrois@polytechnique.org>2021-03-02 16:19:57 +0100
commitc2273d911a8543e566d93ef51f90d9316ad43996 (patch)
tree753e6341c5d39b39201440944651ffb283b88b02
parenta146f483686ffcb76f2a33b17fead72b872b3f68 (diff)
downloadsemantic-version-c2273d911a8543e566d93ef51f90d9316ad43996.tar.gz
Replace setup.py test with nose2
We can't use python -m unittest discover directly, as it mistakenly tries to import the source code of the Django test app without going through the setup_django module first.
-rw-r--r--Makefile2
-rw-r--r--setup.cfg1
2 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 6871485..c617168 100644
--- a/Makefile
+++ b/Makefile
@@ -47,7 +47,7 @@ testall:
# DOC: Run tests for the currently installed version
test:
- python -Wdefault setup.py test
+ python -Wdefault -m nose2
# DOC: Perform code quality tasks
lint: check-manifest flake8
diff --git a/setup.cfg b/setup.cfg
index 778ba33..799dba3 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -36,6 +36,7 @@ install_requires =
dev =
Django>=1.11
# Runners
+ nose2
tox
# Quality
check_manifest