summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--tox.ini18
1 files changed, 7 insertions, 11 deletions
diff --git a/tox.ini b/tox.ini
index 2c2419f..2904df6 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,17 +1,13 @@
[tox]
-envlist = py26,py27,py33,py34,pypy,pypy3
+envlist = py26,py27,py33,py34,py35,pypy,pypy3
[testenv]
deps=
- coverage
- nose
- webob
- webtest
+ nose # Adds nosetests command to setup.py
commands=
- python -bb -m nose tests {posargs}
+ python -bb setup.py nosetests {posargs:--with-coverage}
-[testenv:py26]
-# Ony Python 2.6, python -m test doesn't work. Anyway, python -bb is only
-# interested on Python 3.
-commands=
- nosetests tests {posargs}
+ # We could to this in dependencies, but explicit is better than implicit
+ pip install .[middleware]
+ # webob optional dependency is fulfilled by [middleware] extra requirement
+ python -c "import webob"