summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimeon Visser <svisser@users.noreply.github.com>2014-08-26 01:09:37 +0100
committerSimeon Visser <svisser@users.noreply.github.com>2014-08-26 01:09:37 +0100
commit6504edc5966e597dca703d3a02b1d3f878f5bc9c (patch)
tree463dd75e8e174e57c734e0e33044a54218cfe241
parent709c1770aac577307352d2aae525df5d79fb73c5 (diff)
downloadretrying-6504edc5966e597dca703d3a02b1d3f878f5bc9c.tar.gz
Ensure file handles are closed using with statement
-rw-r--r--setup.py9
1 files changed, 7 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index f6120c7..6e9c219 100644
--- a/setup.py
+++ b/setup.py
@@ -29,12 +29,17 @@ CLASSIFIERS = [
'Topic :: Utilities',
]
+with open('README.rst') as file_readme:
+ readme = file_readme.read()
+
+with open('HISTORY.rst') as file_history:
+ history = file_history.read()
+
settings.update(
name='retrying',
version='1.2.3-dev',
description='Retrying',
- long_description=open('README.rst').read() + '\n\n' +
- open('HISTORY.rst').read(),
+ long_description=readme + '\n\n' + history,
author='Ray Holder',
license='Apache 2.0',
url='https://github.com/rholder/retrying',