summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2021-06-22 13:05:56 -0500
committerJordan Cook <jordan.cook@pioneer.com>2021-07-03 15:44:10 -0500
commita08c39ad6b213eb379df5872de0a695348c82542 (patch)
tree6ad91cb2aaf45d4b62c89e2c33fb3b060b42ce77 /pyproject.toml
parentc4b9e4d4dcad5470de4a30464a6ac8a875615ad9 (diff)
downloadrequests-cache-a08c39ad6b213eb379df5872de0a695348c82542.tar.gz
Some serialization fixes & updates:
* Fix tests on python 3.6: * Make `cattrs` optional again * Don't run tests for serializers with missing optional dependencies * Show any skipped tests in pytest output * Fix redirect serialization for backends that serialize all values (DynamoDB and Redis) * Otherwise, the redirect value (which is just another key) will get converted into a `CachedResponse` * Make `pickle` serializer use `cattrs` if installed * Make `bson` serializer compatible with both `pymongo` version and standalone `bson` library * Split up `CattrStage` and preconf converters into separate modules * Turn preconf converters into `Stage` objects * Add `DeprecationWarning` for previous method of using `itsdangerous`, now that there's a better way to initialize it via `SerializerPipeline` * Remove `suppress_warnings` kwarg that's now unused * Make `SerializerPipeline`, `Stage`, and `CattrStage` importable from top-level package (`from requests_cache import ...`) * Add some more details to docs and docstrings
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 2f553c1..b1c38fb 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -27,6 +27,7 @@ requests = "^2.17"
url-normalize = "^1.4"
# Optional serialization dependencies
+# Note: cattrs will be a hard dependency in a future release, after dropping python 3.6 support
bson = {version = ">=0.5", optional = true}
cattrs = {version = "^1.7", python = "^3.7", optional = true}
ujson = {version = ">=4.0", optional = true}