summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2021-08-03 07:52:18 -0500
committerJordan Cook <jordan.cook@pioneer.com>2021-08-14 21:58:01 -0500
commit707a054da49b3a5ccbac9e16bfb490f1ff65ccb6 (patch)
tree15152b11122a2211cdba89949ea068b5274ca3b9 /pyproject.toml
parentcda90d62c7019307ac28059d7936252e71ddf5b0 (diff)
downloadrequests-cache-707a054da49b3a5ccbac9e16bfb490f1ff65ccb6.tar.gz
Drop support for python 3.6
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml29
1 files changed, 14 insertions, 15 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 80900f4..9357d40 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[tool.poetry]
name = "requests-cache"
-version = "0.7.4"
+version = "0.8.0"
description = "A transparent, persistent cache for the requests library"
authors = ["Roman Haritonov", "Jordan Cook"]
license = "BSD License"
@@ -20,21 +20,20 @@ include = [
"Documentation" = "https://requests-cache.readthedocs.io"
[tool.poetry.dependencies]
-python = "^3.6"
+python = "^3.7"
attrs = "^21.2"
-itsdangerous = ">=2.0.1"
+cattrs = "^1.8"
+itsdangerous = ">=2.0"
requests = "^2.17"
url-normalize = "^1.4"
# Optional serialization dependencies
-# Note: cattrs will be a hard dependency in a future release, after dropping python 3.6 support
bson = {version = ">=0.5", optional = true}
-cattrs = {version = "^1.7", python = "^3.7", optional = true}
ujson = {version = ">=4.0", optional = true}
# Optional backend dependencies
-boto3 = { version = "<1.16", optional = true }
-botocore = { version = "<1.19", optional = true }
+boto3 = { version = "~=1.16.0", optional = true }
+botocore = { version = "~=1.19.0", optional = true }
pymongo = { version = "^3.0", optional = true }
pyyaml = {version = ">=5.4", optional = true}
redis = { version = "^3.0", optional = true }
@@ -50,21 +49,21 @@ sphinxcontrib-apidoc = { version = "^0.3", optional = true }
linkify-it-py = {version = "^1.0.1", optional = true}
[tool.poetry.extras]
-all = ["boto3", "cattrs", "pymongo", "redis", "ujson"]
-bson = ["cattrs", "bson"] # BSON comes with pymongo, and can also be used as a standalone codec
-json = ["cattrs", "ujson"]
-yaml = ["cattrs", "yaml"]
+all = ["boto3", "botocore", "pymongo", "redis", "ujson"]
+bson = ["bson"] # BSON comes with pymongo, and can also be used as a standalone codec
+json = ["ujson"]
+yaml = ["yaml"]
dynamodb = ["boto3", "botocore"]
-mongodb = ["cattrs", "pymongo"]
+mongodb = ["pymongo"]
redis = ["redis"]
docs = ["furo", "linkify-it-py", "myst-parser", "sphinx", "sphinx-autodoc-typehints",
"sphinx-copybutton", "sphinx-inline-tabs", "sphinxcontrib-apidoc"]
[tool.poetry.dev-dependencies]
-nox = {version = "^2021.6.12", python = "^3.6.2"}
-nox-poetry = {version = "^0.8.6", python = "^3.6.2"}
-pre-commit = {version = "^2.12", python = "^3.6.2"}
mypy = "^0.910"
+nox = "^2021.6.12"
+nox-poetry = "^0.8.6"
+pre-commit = "^2.12"
psutil = "^5.0"
pytest = "^6.2"
pytest-clarity = "^1.0.1"