summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <jordan.cook@pioneer.com>2021-06-11 10:50:39 -0500
committerJordan Cook <jordan.cook@pioneer.com>2021-06-11 11:00:49 -0500
commit6d48c1f80f0a47b00984254d5d53b3f1158badee (patch)
treee879e07f02bac787400d4eae4679d492708d8cb8 /pyproject.toml
parent9c6c38b926e6e633b4b29bbb420e2d546ccebadd (diff)
downloadrequests-cache-6d48c1f80f0a47b00984254d5d53b3f1158badee.tar.gz
Add Dependabot V2 config, and bump some dev dependencies
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml15
1 files changed, 7 insertions, 8 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 3977ec3..408cbf9 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -35,9 +35,8 @@ pymongo = { version = "^3.0", optional = true }
redis = { version = "^3.0", optional = true }
# Documentation dependencies
-docutils = { version = "0.16", optional = true }
m2r2 = { version = "^0.2", optional = true }
-Sphinx = { version = "3.5.3", optional = true }
+Sphinx = { version = "4.0.2", optional = true }
sphinx-autodoc-typehints = { version = "^1.11", optional = true }
sphinx-copybutton = { version = "^0.3", optional = true }
sphinx-rtd-theme = { version = "0.5.2", optional = true }
@@ -47,10 +46,10 @@ sphinxcontrib-apidoc = { version = "^0.3", optional = true }
backends = ["boto3", "pymongo", "redis"]
json = ["cattrs"]
docs = ["docutils", "m2r2", "Sphinx", "sphinx-autodoc-typehints", "sphinx-copybutton",
- "sphinx-material", "sphinxcontrib-apidoc"]
+ "sphinx-material", "sphinx-rtd-theme", "sphinxcontrib-apidoc"]
[tool.poetry.dev-dependencies]
-black = {version = "21.5b1", python = ">=3.6.2, <3.10"}
+black = {version = "21.6b0", python = ">=3.6.2, <3.10"}
isort = "^5.8"
flake8 = "^3.9"
flake8-comprehensions = "*"
@@ -58,10 +57,10 @@ flake8-polyfill = "*"
pre-commit = {version = "^2.12", python = "^3.6.2"}
psutil = "^5.0"
pytest = "^6.2"
-pytest-cov = "^2.11"
-pytest-order = "0.11.0"
-pytest-xdist = "^2.2"
-radon = "^4.5"
+pytest-cov = ">=2.11"
+pytest-order = "1.0"
+pytest-xdist = ">=2.2"
+radon = "^5.0"
requests-mock = "^1.8"
rich = ">=10.0"
timeout-decorator = "^0.5"