summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJordan Cook <JWCook@users.noreply.github.com>2021-06-22 11:32:11 -0500
committerGitHub <noreply@github.com>2021-06-22 11:32:11 -0500
commit3beed0e92ee3e0771319c9fa4b9441a1038ffdeb (patch)
tree2d7d3aa309064812af05a68dabebc5396529d988 /pyproject.toml
parent264270d70c9cc895b83903a48eb08314ad0784ea (diff)
parente9b6b414d6b356436032df634f7ee8e5ecc50d8c (diff)
downloadrequests-cache-3beed0e92ee3e0771319c9fa4b9441a1038ffdeb.tar.gz
Merge pull request #286 from parkerhancock/serialization_pipelines
Serialization Pipeline Refactor
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 57e8bd6..2f553c1 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -34,6 +34,7 @@ ujson = {version = ">=4.0", optional = true}
# Optional backend dependencies
boto3 = { version = "^1.17", optional = true }
pymongo = { version = "^3.0", optional = true }
+pyyaml = {version = ">=5.4", optional = true}
redis = { version = "^3.0", optional = true }
# Documentation dependencies
@@ -48,6 +49,7 @@ sphinxcontrib-apidoc = { version = "^0.3", optional = true }
all = ["boto3", "cattrs", "pymongo", "redis", "ujson"]
bson = ["cattrs", "bson"] # BSON comes with pymongo, and can also be used as a standalone codec
json = ["cattrs", "ujson"]
+yaml = ["cattrs", "yaml"]
dynamodb = ["boto3"]
mongodb = ["cattrs", "pymongo"]
redis = ["redis"]