summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMirek Długosz <miniopl+github@gmail.com>2023-04-13 13:56:38 +0200
committerGitHub <noreply@github.com>2023-04-13 14:56:38 +0300
commit7ae8464798f4b3d2eda290c6f49ced14ef7e0029 (patch)
tree5f4870f8962e99052eb43a728b51cf444af7ed36
parente1017fd77afd2f56dca90f986fc82e398e518a26 (diff)
downloadredis-py-7ae8464798f4b3d2eda290c6f49ced14ef7e0029.tar.gz
Really do not use asyncio's timeout lib before 3.11.2 (#2699)
480253037afe4c12e38a0f98cadd3019a3724254 made async-timeout required only on Python 3.11.2 and earlier. However, according to PEP-508, python_version marker is compared to first two numbers of Python version tuple - so it will evaluate to True also on 3.11.3, and install a package as a dependency.
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c23038c..f2935b2 100644
--- a/setup.py
+++ b/setup.py
@@ -34,7 +34,7 @@ setup(
install_requires=[
'importlib-metadata >= 1.0; python_version < "3.8"',
'typing-extensions; python_version<"3.8"',
- 'async-timeout>=4.0.2; python_version<="3.11.2"',
+ 'async-timeout>=4.0.2; python_full_version<="3.11.2"',
],
classifiers=[
"Development Status :: 5 - Production/Stable",