summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGELOG.md62
-rw-r--r--CONTRIBUTORS3
-rw-r--r--rdflib/__init__.py4
3 files changed, 66 insertions, 3 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index b7ac80c1..479d5608 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,65 @@
+2015/02/19 RELEASE 4.2.0
+========================
+
+This is a new minor version of RDFLib including a handful of new features:
+
+* Supporting N-Triples 1.1 syntax using UTF-8 encoding
+ [#447](https://github.com/RDFLib/rdflib/pull/447),
+ [#449](https://github.com/RDFLib/rdflib/pull/449),
+ [#400](https://github.com/RDFLib/rdflib/issues/400)
+* Graph comparison now really works using RGDA1 (RDF Graph Digest Algorithm 1)
+ [#441](https://github.com/RDFLib/rdflib/pull/441)
+ [#385](https://github.com/RDFLib/rdflib/issues/385)
+* More graceful degradation than simple crashing for unicode chars > 0xFFFF on
+ narrow python builds. Parsing such characters will now work, but issue a
+ UnicodeWarning. If you run `python -W all` you will already see a warning on
+ `import rdflib` will show a warning (ImportWarning).
+ [#453](https://github.com/RDFLib/rdflib/pull/453),
+ [#454](https://github.com/RDFLib/rdflib/pull/454)
+* URLInputSource now supports json-ld
+ [#425](https://github.com/RDFLib/rdflib/pull/425)
+* SPARQLStore is now graph aware
+ [#401](https://github.com/RDFLib/rdflib/pull/401),
+ [#402](https://github.com/RDFLib/rdflib/pull/402)
+* SPARQLStore now uses SPARQLWrapper for updates
+ [#397](https://github.com/RDFLib/rdflib/pull/397)
+* Certain logging output is immediately shown in interactive mode
+ [#414](https://github.com/RDFLib/rdflib/pull/414)
+* Python 3.4 fully supported
+ [#418](https://github.com/RDFLib/rdflib/pull/418)
+
+Minor enhancements & bugs fixed:
+--------------------------------
+
+* Fixed double invocation of 2to3
+ [#437](https://github.com/RDFLib/rdflib/pull/437)
+* PyRDFa parser missing brackets
+ [#434](https://github.com/RDFLib/rdflib/pull/434)
+* Correctly handle \uXXXX and \UXXXXXXXX escapes in n3 files
+ [#426](https://github.com/RDFLib/rdflib/pull/426)
+* Logging cleanups and keeping it on stderr
+ [#420](https://github.com/RDFLib/rdflib/pull/420)
+ [#414](https://github.com/RDFLib/rdflib/pull/414)
+ [#413](https://github.com/RDFLib/rdflib/issues/413)
+* n3: allow @base URI to have a trailing '#'
+ [#407](https://github.com/RDFLib/rdflib/pull/407)
+ [#379](https://github.com/RDFLib/rdflib/issues/379)
+* microdata: add file:// to base if it's a filename so rdflib can parse its own
+ output
+ [#406](https://github.com/RDFLib/rdflib/pull/406)
+ [#403](https://github.com/RDFLib/rdflib/issues/403)
+* TSV Results parse skips empty bindings in result
+ [#390](https://github.com/RDFLib/rdflib/pull/390)
+* fixed accidental test run due to name
+ [#389](https://github.com/RDFLib/rdflib/pull/389)
+* Bad boolean list serialization to Turtle & fixed ambiguity between
+ Literal(False) and None
+ [#387](https://github.com/RDFLib/rdflib/pull/387)
+ [#382](https://github.com/RDFLib/rdflib/pull/382)
+* Current version number & PyPI link in README.md
+ [#383](https://github.com/RDFLib/rdflib/pull/383)
+
+
2014/04/15 RELEASE 4.1.2
========================
diff --git a/CONTRIBUTORS b/CONTRIBUTORS
index a8127d1b..51987b61 100644
--- a/CONTRIBUTORS
+++ b/CONTRIBUTORS
@@ -13,6 +13,7 @@ Graham Klyne
Gunnar AAstrand Grimnes
Ivan Herman
Jeroen van der Ham
+Joern Hees
Kendall Clark
Leandro López
Lucio Torre
@@ -26,4 +27,4 @@ Sidnei da Silva
Simon McVittie
Stefan Niederhauser
Thomas Kluyver
-William Waites \ No newline at end of file
+William Waites
diff --git a/rdflib/__init__.py b/rdflib/__init__.py
index 3eea543e..af4785c9 100644
--- a/rdflib/__init__.py
+++ b/rdflib/__init__.py
@@ -30,8 +30,8 @@ A tiny example:
__docformat__ = "restructuredtext en"
# The format of the __version__ line is matched by a regex in setup.py
-__version__ = "4.2.0-dev"
-__date__ = "2015/01/07"
+__version__ = "4.2.0"
+__date__ = "2015/02/19"
__all__ = [
'URIRef',