summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAshley Camba Garrido <ashwoods@gmail.com>2017-08-09 17:08:15 +0200
committerAshley Camba Garrido <ashwoods@gmail.com>2017-08-09 17:12:00 +0200
commitea260cef86a619bcb8e765a2567feef5163024ad (patch)
treefa0a4ad1f40be957cb1c89d4cf542e04778e359a /setup.py
parent911f426a45e987f214d75ddd1a1177d0b70b11c0 (diff)
downloadraven-ea260cef86a619bcb8e765a2567feef5163024ad.tar.gz
Update setup.py and setup.cfg for tox-travis-refactor
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py12
1 files changed, 9 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 7e91788..c7f63a0 100755
--- a/setup.py
+++ b/setup.py
@@ -67,14 +67,20 @@ tests_require = [
'bottle',
'celery>=2.5',
'exam>=0.5.2',
- 'flake8>=2.6,<2.7',
+ 'flake8==3.4.1',
'logbook',
'mock',
'nose',
'pycodestyle',
'pytz',
- 'pytest>=3.0.0,<3.1.0',
- 'pytest-timeout==0.4',
+ 'pytest>=3.1.0,<3.2.0',
+ 'pytest-timeout==1.2.0',
+ 'pytest-xdist==1.18.2',
+ 'pytest-pythonpath',
+ 'pytest-sugar==0.8',
+ 'pytest-assume',
+ 'pytest-cov',
+ 'pytest-flake8',
'requests',
'tornado>=4.1',
'webob',