summaryrefslogtreecommitdiff
path: root/cpp/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'cpp/configure.ac')
-rw-r--r--cpp/configure.ac21
1 files changed, 17 insertions, 4 deletions
diff --git a/cpp/configure.ac b/cpp/configure.ac
index c4e55f90de..f3681073fd 100644
--- a/cpp/configure.ac
+++ b/cpp/configure.ac
@@ -29,6 +29,10 @@ AC_PROG_CXX
AC_USE_SYSTEM_EXTENSIONS
AC_LANG([C++])
+# Check whether a C++ was found (AC_PROG_CXX sets $CXX to "g++" even when it
+# doesn't exist)
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],[])],[],[AC_MSG_ERROR([No C++ compiler found])])
+
# Check for optional use of help2man
AC_CHECK_PROG([HELP2MAN], [help2man], [help2man])
AC_ARG_WITH([help2man],
@@ -146,7 +150,7 @@ AM_CONDITIONAL([HAS_RPMLINT], [test -n "$RPMLINT"])
AC_CHECK_PROG([RUBY], [ruby], [ruby])
# Swig binding generator is needed for the script (Ruby, Python, etc.) bindings.
-AC_PROG_SWIG(1.3.26)
+AC_PROG_SWIG(1.3.32)
test ! -x "$SWIG" && SWIG=""
AC_ARG_WITH([swig],
[AS_HELP_STRING([--with-swig], [Use swig to generate qmf bindings.])],
@@ -210,10 +214,11 @@ AS_IF([test -n "$PYTHON"], [
# location
AC_MSG_WARN([Didn't find Python 2.7 developer libs - looking for older version])
PYTHON_INC=$($PYTHON -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_inc()')
- AC_CHECK_LIB([python$PYTHON_VERSION],[Py_Initialize])
+ AC_CHECK_LIB([python$PYTHON_VERSION],[Py_Initialize],[
+ PYTHON_LIBS="-lpython$PYTHON_VERSION"
+ ])
AC_CHECK_FILE(["$PYTHON_INC/Python.h"],[
PYTHON_CFLAGS="-I$PYTHON_INC"
- PYTHON_LIBS="-lpython$PYTHON_VERSION"
have_python_dev=yes
],[
if test yes = "$with_python" ; then
@@ -296,6 +301,15 @@ AS_IF([test "x$WANT_SASL" != xno],
AM_CONDITIONAL([HAVE_SASL], [test "x$have_sasl" = xyes])
AC_SUBST([SASL_PASSWD])
+# Allow integration against external AMQP 1.0 protocol engine
+AC_ARG_WITH([proton], AS_HELP_STRING([--with-proton], [Build with the proton toolkit for AMQP 1.0 support]))
+
+AS_IF([test "x$with_proton" = "xyes"], [
+ PKG_CHECK_MODULES([PROTON], [libqpid-proton])
+])
+AM_CONDITIONAL([HAVE_PROTON], [test "x$with_proton" = "xyes"])
+
+
# Setup --with-xml/--without-xml as arguments to configure
use_xml=yes
want_xml=check
@@ -525,7 +539,6 @@ AC_CONFIG_FILES([
managementgen/Makefile
etc/Makefile
src/Makefile
- src/tests/cpg_check.sh
src/tests/Makefile
src/tests/test_env.sh
src/tests/install_env.sh