summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2012-12-13 21:32:30 +1300
committerRobert Collins <robertc@robertcollins.net>2012-12-13 21:32:30 +1300
commit7d5ea56d1f22af33f6182e84b1f55ccc84fbb5cf (patch)
treeac23bc51c96af1343d152626768120dc1239d45e
parenta21a427fc3629e4bcb208618b3de3772a6e67d41 (diff)
downloadpython-test-extras-7d5ea56d1f22af33f6182e84b1f55ccc84fbb5cf.tar.gz
Release 0.0.2, removing Makefile cruft.0.0.2
-rw-r--r--Makefile32
-rw-r--r--NEWS5
-rw-r--r--extras/__init__.py2
3 files changed, 9 insertions, 30 deletions
diff --git a/Makefile b/Makefile
index 9d5b515..270e8d1 100644
--- a/Makefile
+++ b/Makefile
@@ -12,21 +12,10 @@ TAGS: ${SOURCES}
tags: ${SOURCES}
ctags -R extras/
-clean: clean-sphinx
+clean:
rm -f TAGS tags
find extras -name "*.pyc" -exec rm '{}' \;
-prerelease:
- # An existing MANIFEST breaks distutils sometimes. Avoid that.
- -rm MANIFEST
-
-release:
- ./setup.py sdist upload --sign
- $(PYTHON) scripts/_lp_release.py
-
-snapshot: prerelease
- ./setup.py sdist
-
### Documentation ###
apidocs:
@@ -36,21 +25,6 @@ apidocs:
--docformat=restructuredtext --project-name=extras \
--project-url=https://launchpad.net/extras
-doc/news.rst:
- ln -s ../NEWS doc/news.rst
-
-docs: doc/news.rst docs-sphinx
- rm doc/news.rst
-
-docs-sphinx: html-sphinx
-
-# Clean out generated documentation
-clean-sphinx:
- cd doc && make clean
-
-# Build the html docs using Sphinx.
-html-sphinx:
- cd doc && make html
-.PHONY: apidocs docs-sphinx clean-sphinx html-sphinx docs
-.PHONY: check clean prerelease release
+.PHONY: apidocs
+.PHONY: check clean
diff --git a/NEWS b/NEWS
index 26a081c..a39cc76 100644
--- a/NEWS
+++ b/NEWS
@@ -6,6 +6,11 @@ Changes and improvements to extras_, grouped by release.
NEXT
~~~~
+0.0.2
+~~~~~
+
+Fix Makefile to not have cruft leftover from testtools.
+
0.0.1
~~~~~
diff --git a/extras/__init__.py b/extras/__init__.py
index 1ad7437..2d4a44e 100644
--- a/extras/__init__.py
+++ b/extras/__init__.py
@@ -22,7 +22,7 @@ __all__ = [
# If the releaselevel is 'final', then the tarball will be major.minor.micro.
# Otherwise it is major.minor.micro~$(revno).
-__version__ = (0, 0, 2, 'dev', 0)
+__version__ = (0, 0, 2, 'final', 0)
def try_import(name, alternative=None, error_callback=None):