summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2022-11-18 20:36:21 +0200
committerGitHub <noreply@github.com>2022-11-18 13:36:21 -0500
commita229e483b6f82f36600e73e7a2fb62dc2f5e7ed3 (patch)
treec80060753bcd69a9e857bcea0c8e1ce03aab7bc0 /setup.py
parentdbe74897764eb8338151e09cfc611e90cef12280 (diff)
downloadpython-slugify-a229e483b6f82f36600e73e7a2fb62dc2f5e7ed3.tar.gz
Add support for Python 3.11 (#121)
* Add support for Python 3.11 * Drop support for EOL Python 3.6
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index c3c4b3b..65c72f4 100755
--- a/setup.py
+++ b/setup.py
@@ -9,7 +9,7 @@ from setuptools import setup
package = 'slugify'
-python_requires = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*, !=3.5.*"
+python_requires = ">=3.7"
here = os.path.abspath(os.path.dirname(__file__))
install_requires = ['text-unidecode>=1.3']
@@ -75,11 +75,11 @@ setup(
'License :: OSI Approved :: MIT License',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
],
entry_points={'console_scripts': ['slugify=slugify.__main__:main']},
)