summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Wojcik <wojcikstefan@gmail.com>2016-09-28 16:19:09 -0400
committerStefan Wojcik <wojcikstefan@gmail.com>2016-09-28 16:19:09 -0400
commita9e21a9d556ea236721fe2e7f9b1260127d22a04 (patch)
treefd9d04e911dfdc9b7b2396b90e4c8ec0cf70a8d2 /setup.py
parent7799be4a1cd2d68f70293a515bba1392b989531b (diff)
downloadpython-mimeparse-a9e21a9d556ea236721fe2e7f9b1260127d22a04.tar.gz
setup.py sanity check + pep8 tweaks to mimeparse.py
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4d395ea..e0ba146 100755
--- a/setup.py
+++ b/setup.py
@@ -15,6 +15,8 @@ def get_version(filename):
return re.search("__version__ = ['\"]([^'\"]+)['\"]", contents).group(1)
version = get_version('mimeparse.py')
+if not version:
+ raise RuntimeError('Cannot find version information')
def read(fname):
@@ -22,6 +24,7 @@ def read(fname):
with codecs.open(path, encoding='utf-8') as fp:
return fp.read()
+
setup(
name="python-mimeparse",
py_modules=["mimeparse"],