summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorD.B. Tsai <dbtsai@dbtsai.com>2012-08-22 21:39:55 -0700
committerD.B. Tsai <dbtsai@dbtsai.com>2012-08-27 20:02:49 -0700
commita63b32c7a7673ccfd24593ed69e57e43edfefb1b (patch)
tree5f644b971f84e98fecbea57592e24845e4baa216 /setup.py
parent0ae0ebf94de6366490e0b2ed62d36c0ba5cc5e99 (diff)
downloadpython-mimeparse-a63b32c7a7673ccfd24593ed69e57e43edfefb1b.tar.gz
Uploaded to PyPI using python-mimeparse as package name.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py57
1 files changed, 25 insertions, 32 deletions
diff --git a/setup.py b/setup.py
index 0f2821b..2369456 100755
--- a/setup.py
+++ b/setup.py
@@ -1,41 +1,34 @@
#!/usr/bin/env python
-# -*- coding: utf-8 -*-
+import os
+import mimeparse
from setuptools import setup
-setup(
- name='mimeparse',
- version='0.1.3',
- description='A module provides basic functions for parsing mime-type names and matching them against a list of media-ranges.',
- long_description="""
-This module provides basic functions for handling mime-types. It can handle
-matching mime-types against a list of media-ranges. See section 14.1 of
-the HTTP specification [RFC 2616] for a complete explanation.
- http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html#sec14.1
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
-Contents:
- - parse_mime_type(): Parses a mime-type into its component parts.
- - parse_media_range(): Media-ranges are mime-types with wild-cards and a 'q' quality parameter.
- - quality(): Determines the quality ('q') of a mime-type when compared against a list of media-ranges.
- - quality_parsed(): Just like quality() except the second parameter must be pre-parsed.
- - best_match(): Choose the mime-type with the highest quality ('q') from a list of candidates.
- """,
+setup(
+ name="python-mimeparse",
+ py_modules=["mimeparse"],
+ version=mimeparse.__version__,
+ description=("A module provides basic functions for parsing mime-type "
+ "names and matching them against a list of media-ranges."),
+ author="David Tsai",
+ author_email="dbtsai@dbtsai.com",
+ url="https://github.com/dbtsai/python-mimeparse",
+ download_url=("http://pypi.python.org/packages/source/p/python-mimeparse/"
+ "python-mimeparse-" + mimeparse.__version__ + ".tar.gz"),
+ keywords=["mime-type"],
classifiers=[
- # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Programming Language :: Python',
- 'Topic :: Internet :: WWW/HTTP',
- 'Topic :: Software Development :: Libraries :: Python Modules',
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "Topic :: Internet :: WWW/HTTP",
+ "Topic :: Software Development :: Libraries :: Python Modules",
],
- keywords='mime-type',
- author='Joe Gregorio',
- author_email='joe@bitworking.org',
- maintainer='Joe Gregorio',
- maintainer_email='joe@bitworking.org',
- url='http://code.google.com/p/mimeparse/',
- license='MIT',
- py_modules=['mimeparse'],
- zip_safe=True,
+ long_description=read('README')
)