summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMartin Thoma <info@martin-thoma.de>2018-06-17 09:36:34 +0200
committerMartin Thoma <info@martin-thoma.de>2018-06-17 09:36:34 +0200
commitc32273d3989b50bb65b76ff0be8e8450719d9d38 (patch)
treecf7fd6db3df87fb750bad9dfe16125c221e2eb0f /setup.py
parent3ca954869ee5f3e55a3d413bea2a90e88387cfe4 (diff)
downloadpython-magic-c32273d3989b50bb65b76ff0be8e8450719d9d38.tar.gz
Improve project page on PyPI
See https://pypi.org/project/python-magic/
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py15
1 files changed, 11 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index ca702c1..2d56cec 100644
--- a/setup.py
+++ b/setup.py
@@ -2,6 +2,15 @@
# -*- coding: utf-8 -*-
from setuptools import setup
+import io
+import os
+
+
+def read(file_name):
+ """Read a text file and return the content as a string."""
+ with io.open(os.path.join(os.path.dirname(__file__), file_name),
+ encoding='utf-8') as f:
+ return f.read()
setup(name='python-magic',
description='File type identification using libmagic',
@@ -10,10 +19,8 @@ setup(name='python-magic',
url="http://github.com/ahupp/python-magic",
version='0.4.15',
py_modules=['magic'],
- long_description="""This module uses ctypes to access the libmagic file type
-identification library. It makes use of the local magic database and
-supports both textual and MIME-type output.
-""",
+ long_description=read('README.md'),
+ long_description_content_type='text/markdown',
keywords="mime magic file",
license="MIT",
test_suite='test',