summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Simionato <michele.simionato@gmail.com>2022-11-06 07:39:36 +0100
committerGitHub <noreply@github.com>2022-11-06 07:39:36 +0100
commitb496c55fa3b0fdd9ce955d36879d943aa00ec438 (patch)
treeaccb883491075bbec01b932f9ef067a405d589a7
parent6f4cf6f01e81c860ab0add4580f73e099bf8abba (diff)
parent099462d9355a3d92942b414c11e143b916b35b72 (diff)
downloadpython-decorator-git-b496c55fa3b0fdd9ce955d36879d943aa00ec438.tar.gz
Merge pull request #147 from hugovk/master
Add support for Python 3.11
-rw-r--r--.github/workflows/python-package.yml2
-rw-r--r--CHANGES.md2
-rw-r--r--docs/documentation.md6
-rw-r--r--setup.py1
-rw-r--r--src/tests/documentation.py6
5 files changed, 9 insertions, 8 deletions
diff --git a/.github/workflows/python-package.yml b/.github/workflows/python-package.yml
index d527946..fda580a 100644
--- a/.github/workflows/python-package.yml
+++ b/.github/workflows/python-package.yml
@@ -15,7 +15,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: ['3.5', '3.6', '3.7', '3.8', '3.9', '3.10']
+ python-version: ['3.5', '3.6', '3.7', '3.8', '3.9', '3.10', '3.11']
steps:
- uses: actions/checkout@v2
diff --git a/CHANGES.md b/CHANGES.md
index 36a5877..f76724b 100644
--- a/CHANGES.md
+++ b/CHANGES.md
@@ -32,7 +32,7 @@ lacking dunder attributes, like `dict.__setitem__`.
## 5.0.7 (2021-04-14)
The decorator module was not passing correctly the defaults inside the
-`*args` tuple, thanks to Dan Shult for the fix. Also fixed some mispellings
+`*args` tuple, thanks to Dan Shult for the fix. Also fixed some misspellings
in the documentation and integrated codespell in the CI, thanks to
Christian Clauss.
diff --git a/docs/documentation.md b/docs/documentation.md
index 10ddb5f..cc92eb9 100644
--- a/docs/documentation.md
+++ b/docs/documentation.md
@@ -4,8 +4,8 @@
|---|---|
|E-mail | michele.simionato@gmail.com|
|Version| 5.1.1 (2022-01-07)|
-|Supports| Python 3.5, 3.6, 3.7, 3.8, 3.9, 3.10|
-|Download page| http://pypi.python.org/pypi/decorator/5.1.1|
+|Supports| Python 3.5, 3.6, 3.7, 3.8, 3.9, 3.10, 3.11|
+|Download page| https://pypi.org/project/decorator/5.1.1|
|Installation| ``pip install decorator``|
|License | BSD license|
@@ -1492,7 +1492,7 @@ with ``functools.singledispatch``, the assertion will break: ``g`` will return
will insert the ``Container`` class right before ``S``.
Notice that here I am not making any bold claim such as "the standard
-library algorithm is wrong and my algorithm is right" or viceversa. It
+library algorithm is wrong and my algorithm is right" or vice versa. It
just point out that there are some subtle differences. The only way to
understand what is really happening here is to scratch your head by
looking at the implementations. I will just notice that
diff --git a/setup.py b/setup.py
index e7b758d..d71c24b 100644
--- a/setup.py
+++ b/setup.py
@@ -31,6 +31,7 @@ if __name__ == '__main__':
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
'Programming Language :: Python :: Implementation :: CPython',
'Topic :: Software Development :: Libraries',
'Topic :: Utilities'],
diff --git a/src/tests/documentation.py b/src/tests/documentation.py
index bf3a0b0..bbbe562 100644
--- a/src/tests/documentation.py
+++ b/src/tests/documentation.py
@@ -14,8 +14,8 @@ doc = r"""# Decorators for Humans
|---|---|
|E-mail | michele.simionato@gmail.com|
|Version| $VERSION ($DATE)|
-|Supports| Python 3.5, 3.6, 3.7, 3.8, 3.9, 3.10|
-|Download page| http://pypi.python.org/pypi/decorator/$VERSION|
+|Supports| Python 3.5, 3.6, 3.7, 3.8, 3.9, 3.10, 3.11|
+|Download page| https://pypi.org/project/decorator/$VERSION|
|Installation| ``pip install decorator``|
|License | BSD license|
@@ -1171,7 +1171,7 @@ with ``functools.singledispatch``, the assertion will break: ``g`` will return
will insert the ``Container`` class right before ``S``.
Notice that here I am not making any bold claim such as "the standard
-library algorithm is wrong and my algorithm is right" or viceversa. It
+library algorithm is wrong and my algorithm is right" or vice versa. It
just point out that there are some subtle differences. The only way to
understand what is really happening here is to scratch your head by
looking at the implementations. I will just notice that