summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2022-11-05 23:34:08 +0200
committerHugo van Kemenade <hugovk@users.noreply.github.com>2022-11-05 23:34:08 +0200
commit124f5c358c6a18b1a647e122cf88686a449552f9 (patch)
tree88d6353485059cbba014be92f1bb9b0373e33e6e
parent6f4cf6f01e81c860ab0add4580f73e099bf8abba (diff)
downloadpython-decorator-git-124f5c358c6a18b1a647e122cf88686a449552f9.tar.gz
Add support for Python 3.11
-rw-r--r--.github/workflows/python-package.yml2
-rw-r--r--docs/documentation.md2
-rw-r--r--setup.py1
-rw-r--r--src/tests/documentation.py2
4 files changed, 4 insertions, 3 deletions
diff --git a/.github/workflows/python-package.yml b/.github/workflows/python-package.yml
index d527946..fda580a 100644
--- a/.github/workflows/python-package.yml
+++ b/.github/workflows/python-package.yml
@@ -15,7 +15,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: ['3.5', '3.6', '3.7', '3.8', '3.9', '3.10']
+ python-version: ['3.5', '3.6', '3.7', '3.8', '3.9', '3.10', '3.11']
steps:
- uses: actions/checkout@v2
diff --git a/docs/documentation.md b/docs/documentation.md
index 10ddb5f..766af7a 100644
--- a/docs/documentation.md
+++ b/docs/documentation.md
@@ -4,7 +4,7 @@
|---|---|
|E-mail | michele.simionato@gmail.com|
|Version| 5.1.1 (2022-01-07)|
-|Supports| Python 3.5, 3.6, 3.7, 3.8, 3.9, 3.10|
+|Supports| Python 3.5, 3.6, 3.7, 3.8, 3.9, 3.10, 3.11|
|Download page| http://pypi.python.org/pypi/decorator/5.1.1|
|Installation| ``pip install decorator``|
|License | BSD license|
diff --git a/setup.py b/setup.py
index e7b758d..d71c24b 100644
--- a/setup.py
+++ b/setup.py
@@ -31,6 +31,7 @@ if __name__ == '__main__':
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
'Programming Language :: Python :: Implementation :: CPython',
'Topic :: Software Development :: Libraries',
'Topic :: Utilities'],
diff --git a/src/tests/documentation.py b/src/tests/documentation.py
index bf3a0b0..375bb57 100644
--- a/src/tests/documentation.py
+++ b/src/tests/documentation.py
@@ -14,7 +14,7 @@ doc = r"""# Decorators for Humans
|---|---|
|E-mail | michele.simionato@gmail.com|
|Version| $VERSION ($DATE)|
-|Supports| Python 3.5, 3.6, 3.7, 3.8, 3.9, 3.10|
+|Supports| Python 3.5, 3.6, 3.7, 3.8, 3.9, 3.10, 3.11|
|Download page| http://pypi.python.org/pypi/decorator/$VERSION|
|Installation| ``pip install decorator``|
|License | BSD license|