summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2022-02-25 11:24:15 -0500
committerJason R. Coombs <jaraco@jaraco.com>2022-02-25 11:24:15 -0500
commitb2a1ed2b28a3739f36cbe19f611c6ea8be76d63f (patch)
tree9726e733bf3c47a71d9ebd802a83798f0caa7555
parentb227bc27365f620f67305c2ec85b67cba1550388 (diff)
downloadpytest-runner-b2a1ed2b28a3739f36cbe19f611c6ea8be76d63f.tar.gz
Update test to install pytest-runner using pip.
-rw-r--r--tests/test_ptr.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/tests/test_ptr.py b/tests/test_ptr.py
index f6eac16..94f5f58 100644
--- a/tests/test_ptr.py
+++ b/tests/test_ptr.py
@@ -55,8 +55,7 @@ args_variants = ['', '--extras']
def test_egg_fetcher(venv, setuptools_req, test_args):
test_args = test_args.split()
# Install pytest & pytest-runner.
- venv.run('python setup.py develop', cwd=os.getcwd())
- venv.run('pip install pytest')
+ venv.run('pip install pytest .', cwd=os.getcwd())
# Install setuptools version.
venv.run('pip install -U'.split() + [setuptools_req])
# For debugging purposes.